Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of January's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
i have a 99 TJ SE. when i bought it it had a shitty aftermarket radio so i bought a stock one for cheap. the radio doesnt seem to work though, it only displays the time for a couple minutes on and off. none of the buttons do anything but there is definetly power going to the radio. most of the time the thing is completly dead except for the couple minutes that it likes to display the time. is there some secret jeep radio quirk i don't know about?
 

·
Registered
Joined
·
17,486 Posts
Both stock and aftermarket non can bus (wrangler went to can bus in 2007) radios have to have both battery power and accessory key on power so they know to shut down when key is in off position

Post a picture of the radio you have

A lot of good info on stock keep/dodge Chrysler head units here


One interesting comment from this link

“ You could even get the time with the ignition off by pressing the volume knob, a welcome feature that continues on many Chrysler decks to this day. “

So my guess is that is how you got time to display without an on/accessory power source hocked up


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Both stock and aftermarket non can bus (wrangler went to can bus in 2007) radios have to have both battery power and accessory key on power so they know to shut down when key is in off position

Post a picture of the radio you have

A lot of good info on stock keep/dodge Chrysler head units here


One interesting comment from this link

“ You could even get the time with the ignition off by pressing the volume knob, a welcome feature that continues on many Chrysler decks to this day. “

So my guess is that is how you got time to display without an on/accessory power source hocked up


Sent from my iPhone using Tapatalk
4502670
this is the radio model i have
 

·
Registered
Joined
·
17,486 Posts
That deck is built by alpine has three band equalizer and was used in the cloud series cars of the late 90s


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17,486 Posts
Sounds like you have plus 12 to battery wire but not yet properly connected to plus 12 from accessory key wire

Pin7 on the gray connector goes to battery always plus 12 and pin 6 on the same gray connector must get plus12 when key is in accessory or on position or radio will not function

Pin 1 on same gray connector is not used


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top