Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
1,031 Posts
Discussion Starter · #1 ·
Heres my problem. When I use my winch, I will get a burning smell. From research, I would believe it is the alternator burning up. So I stopped using my winch until I can buy a deep cycle battery suitable for winching.Today at a local pit, some douche pulled out a old boat hull that was in the woods. No deck cap or anything, just the hull. Anyway, I tied a tow strap to it but could only do it to the stern so it was hard to pull. After a few drives and moving it 10 ft, it smelled like my alternator was burning again. I really try to use the clutch the least amount possible so I don't think its the clutch. I was in 4-high. Later when i shut my jeep off and tried to start it again, the starter just kept clicking and the dashboard was lighting on and off. I went out and tapped the starter with a hammer and then it started. Is a bigger problem than i think or will a battery solve this all. If the answer is a battery, what would you recommend. I will be doing some more research but you guys are so helpful here and I could learn a few more things probably
 

·
Registered
Joined
·
176 Posts
Before you run out and replace the battery maybe go somewhere that can test the battery and charging system voltage.(if your system is overcharging and or your battery is dry you could get a rotten egg smell)

Needing to tap the starter to get it to work is usually a sign that the brushes on your starter are wearing out and not seating/making contact, the tap causes the brushes to seat/make conatct, I would consider this a seperate issue(though if your battery/charging system is bad it can cause your starter to burn out as you may be operating at a lower voltage which can cause the starter to draw a higher amperage.)

For the burning smell unless you find a bad connection and since you are getting it while not using the winch I would look for an oil or other fluid leak that is getting on the engine or exhaust.
 

·
Registered
Joined
·
1,031 Posts
Discussion Starter · #3 ·
thank you for the response. Where should I start looking for a bad connection?
 

·
Registered
Joined
·
1,031 Posts
Discussion Starter · #4 ·
Battery was dead today when I tried to start. Didn't leave anything on so I don't know why. Jumped it When driving to school this morning, check Gauges light came on and saw my volt meter was at 19+. So I turned the car off while still moving and turned her back on at it went back to normal(14). I'm going to get a new battery today.
 
1 - 4 of 4 Posts
Top