Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
SO , my front wheels have noticeable positive camber , i at first thought it was the balljoints because thats what i was told when i went to NTB to get an alignement... so I went to get a second opinion from a mechanic friend of mine and he checked the ball joints and they were fine. He is going to try and do an alignment on it and see if he can fix it, however, as far as i know you cant adjust the camber on these things so im thinking an alignment wont fix it, what else could the problem be ? Tie Rods? Hub? If anyone else has had this problem let me know what it was on yours, thanks.

camber.jpg
 

·
Registered
Joined
·
1,207 Posts
I cannot imagine how that is possible without something(s) being bent; your whole axle would have to be tweaked for that to happen.

are you sure its camber and not toe?
 

·
Registered
Joined
·
180 Posts
Discussion Starter #4
postive, he set the toe already and my tires look just like the pic on the bottom. I dunno what it could be either.
 

·
Registered
Joined
·
1,207 Posts
Now caster sounds right, although what year rig? is it coil or leaf spring front.

If leaf, Im not sure you can do much with caster except installing shims on the axle between the leafs.

If coil, Im not familiar with adjusting on those.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #7
Now caster sounds right, although what year rig? is it coil or leaf spring front.

If leaf, Im not sure you can do much with caster except installing shims on the axle between the leafs.

If coil, Im not familiar with adjusting on those.
yeah its a leaf front, anyway, Im replacing the tie rods this weekend so im gonna go get an alignment after that and we'll see if he can fix it up or not
 
1 - 7 of 7 Posts
Top