Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 97 TJ , when it's cold it spits and sputters unless I let it warm up to about 150 deg . Then it runs great ! The check engine light comes on and is showing misfires on all cylinders and a P300 code , but if I clear it and only start it when it's warm it doesn't happen and the light won't come on . It's a 4.0 L with auto and a/c
 

·
Registered
Joined
·
2,382 Posts
Multiple misfires would lead me to the distributor and or coil.
Also take a look at your main grounds and power leads off the battery.

You may have a poor connection when cold that is causing a weak spark from the distributor/coil.

Or you could have a faulty cap/rotor/coil. Something as simple as a crack. When it's cold the crack is open, as it heats up the material expands and the crack seals.


And start with the basics. Even a poor/old tune up can make an engine run poorly cold and seemingly fine when warm.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I have changed cap , rotor , wires and plugs . I need to change the coil and check the battery , it shows a 12 on the code and I have not had the battery off . Thanks for your help .
I keep reading about bad valve springs but I'm confused :) if it was that would it run bad all the time ?
 

·
Knows a couple things...
Joined
·
49,616 Posts
The 12 code (saying the battery has been disconnected in recent history) is no big deal, my previous '97 TJ seemed to have a 12 code most of the time which causes no problems.

Bad valve springs will cause intermittent misfire problems even if the engine is warm so I doubt that is your problem. Since you have changed the most obvious items with no change to your symptoms, I'd next try swapping the ignition coil. My '97 went through two ignition coils in the 14 years I owned it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I'm going to try that , and anything else I can before I go to the valve springs . It runs too good and not showing a misfire on 1 or 2 cylinders , it's all of them .
I am new to the forum and thanks for your help !!!
 

·
Registered
Joined
·
2,473 Posts
weak valve springs? All of a sudden?

What are the odds of several springs suddenly becoming too weak at once? And then, suddenly becoming strong again when warm?

It might be believable if the OP overheated it bad, but there should be other "worse"symptoms too.

Something common to all cylinders - coil, coil wire, rotor.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
That's my feeling as well , but I have been wrong before , I will try the coil after new years gonna use the TJ tonight at the mud park :) , I'll let you know if that works .
Happy New Year everyone !
 
1 - 8 of 8 Posts
Top