Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 21 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Anyone out in Jeep land have a good cat with O2 sensor for a 99 for sale. We just bought 99 and are discovering many issues with it. It was inspected and passed a emissions test but was running real bad. When I took it in to find out why they informed me that it HAS NO CATALYTIC CONVERTER on it. Any help would be great
 

·
Registered
Joined
·
1,321 Posts
Davey'sjeeps is a good source for parts.
 

·
Sponsoring Vendor
'13 JK
Joined
·
4,689 Posts
"... they informed me that it HAS NO CATALYTIC CONVERTER on it ... "

Did they show you this? You looked at it yourself to see what had been modified?


Just curious.


.
 

·
Registered
Joined
·
1,487 Posts
You say your Jeep has no cat and, more importantly, no oxygen sensor. Also, it is running "real bad" according to you. Yet despite all this, it still managed to pass an emissions test?

To say this story sounds fishy would be an epic understatement.
 

·
Registered
Joined
·
597 Posts
as others jave said or implied. . you do have a cat. . or you would bit have passed.. it is probably clogged witch is why it runs like :censored:. .. who ever told you it wasn't there didnt mean leterly. .

if you really dont have one.. hopefully you have a friend who knows what he is doing most shops will not tuch a cat less vhiical..

liveing in a state with no inspection I run with out. . it runs better with out.. and get a few more mpg to the tank.. you are not this lucky

replaceing them isnt hard.. I was quoted 200 parts and labor include on a s10 few years back im sure jeep will be similar.. I just cut it off and put straight pipe in and scraped the old cat.. made money on the job..
 

·
Registered
Joined
·
1,808 Posts
No power at all. I have driven other jeeps with the same setup as my sons jeep has and it's a compleat dog. It has a very rough idle and no power at any rpm or speed
Very simple issue. Your cat is clogged. If you had no cats (like mine) it would be running like normal, except a little louder.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #14 ·
Very simple issue. Your cat is clogged. If you had no cats (like mine) it would be running like normal, except a little louder.
That is the problem! There is no CAT. It was cut out by the previous owner.
 

·
Registered
Joined
·
338 Posts
You've seen that the cat AND the upstream O2 sensor have been cut out? Or someone has told you that? Pictures would help you a lot here. If the O2 sensor has been cut out take it to an exhaust shop have them put an O2 sensor housing(?) near the start of the pipe where your upstream O2 sensor connector is and boom you're good
 

·
Registered
Joined
·
597 Posts
That is the problem! There is no CAT. It was cut out by the previous owner.
you wouldn't have passed your test


but if you some how did.. go to a certified mechanic you trust.. and take the bill to the PO.. by law he has to pay for it.. has to be certified tho.. you cant do it your self unless you where certified (witch i take it as your not or this thread wouldn't be here)
 

·
Registered
Joined
·
35 Posts
Don't mean to jack this thread but is this true...if you don't have a cat will cel stay on? Thanks
I have seen people strap their down stream O2 sensor up out of the way when there is no cat. This then reads clean air and they haven't had a problem with cel's
 

·
Registered
Joined
·
1,808 Posts
I have seen people strap their down stream O2 sensor up out of the way when there is no cat. This then reads clean air and they haven't had a problem with cel's
You put a spacer or a "spark plug nonfouler" in between the tube and o2 sensor. This will trick the sensor into thinking that the air is cleaner then it really is. I wouldn't recommend taking the sensor out and leave it dangling.
 

·
Registered
Joined
·
202 Posts
I have seen people strap their down stream O2 sensor up out of the way when there is no cat. This then reads clean air and they haven't had a problem with cel's
This what I've got now I don't see a cat except for the O2 sensor.

image-3094161774.jpg

I'm not quiet sure how strap it correctly (dang it) would you please elaborate.
To the op my apologies.
 
1 - 20 of 21 Posts
Top