Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 20 of 34 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
I have a 4 month old JK and ever since I got it have noticed that when pushing up (right turn indicator) on the turn signal lever sometimes it feels like it is catching and doesn't want to stick in position. Other times it works just fine. Does anyone else experience this? All other vehicles I have owned always feel crisp and click into position with ease. Just wonder if it is another Wrangler thing.

:rolleyes:
 

·
Registered
Joined
·
208 Posts
Mine doesn't seem to have any problems, but neither is it a smooth luxurious feel. It kinda clicked into place a little roughly, but it never has seemed like it had problems.
 

·
Registered
Joined
·
62 Posts
it happens to me too.I believe that it has to do with the position of the steering wheel. I have not taken the time to test it though. It is only the right turn signal.
 

·
Registered
Joined
·
92 Posts
me too
 

·
Registered
Joined
·
95 Posts
Happens to me as well, an '11 JK with 800miles. Thought it was just in my head. Also feels like the issue is exaggerated when I have the factory fogs on.
 

·
Registered
Joined
·
4,718 Posts
This is so true I thought I had a problem or was a little slow but it happens all the time sometimes causing me to flash my high beams too :Banghead:
 

·
Registered
Joined
·
26,921 Posts
Mine doesn't seem to have any problems, but neither is it a smooth luxurious feel. It kinda clicked into place a little roughly, but it never has seemed like it had problems.
My experience too.
 

·
Registered
Joined
·
1,534 Posts
Mine does too. Feels mushy. Also, God forbid you turn it on and then have to turn the wheel slightly to the right...it just clicks off. It's really annoying to me.
 

·
Registered
Joined
·
208 Posts
I have noticed it too but I have attributed it to the "changing lanes" feature in which you don't fully engage the turn signal and it "flashes" 3 times and goes off
 

·
Registered
Joined
·
1,738 Posts
It is a tap feature, you tap the stick up or down and it blinks 3 times then shuts off. For permanent engagement, a much more significant amount of force needs to be used on the stick.

Lane Change Assist

Tap the lever up or down once, without moving beyond
the detent, and the turn signal (right or left) will flash
three times then automatically turn off.
 

·
Registered
Joined
·
51 Posts
happens to me all the time on my 07. its a tap feature, but its not very well implemented. sometimes it simply wont stay in place with any amount of force. one of these days im gonna rage on it & end up tearing it off.
 

·
Registered
Joined
·
27 Posts
kramer2k said:
How would the ProCal solve a seemingly mechanical quirk? :confused: This seems to be an issue of the plastic and detent feature not being quite as smooth as most other vehicles. This isn't really an electrical issue.
There is a "one touch lane change" feature that you can activate.
No longer blinks three times, and doesn't seem to get stuck anymore.
 

·
Registered
Joined
·
8,968 Posts
When I use it for a right turn I don't push it up from the end of the stalk. I push it up approx. 2-3" in from the end and it operates better.
 

·
Registered
Joined
·
1,678 Posts
happens to me all the time on my 07. its a tap feature, but its not very well implemented. sometimes it simply wont stay in place with any amount of force. one of these days im gonna rage on it & end up tearing it off.
My feelings exactly, I really wish they put a normal blinker in this thing, one that isn't so finicky. I prefer to have it positively ON, or positively OFF, and not to shutoff with what seems like such a minute change in the steering wheel.
 

·
Registered
Joined
·
14 Posts
I just asked my buddy to see if his does this last night. Drives me nuts. It seems like the angle just doesn't line up with the steering wheel. i can do it almost fine if i think about it. shouldn't need to on a new 15.
 
1 - 20 of 34 Posts
Top