Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
So I installed a cb and mounted the antenna using a teraflex rear break light mount. The whole install went pretty easy. Except I had a little trouble tuning the antenna so from reading some other threads I figured out I needed to grind the powder coat off the mount (top & bottom). No problem there either got it tuned to about 1.3 on ch 20. But I guess I ground a little too much area around antenna an it started to rust within about 24hrs. Not sure what to do. Thinking about cleaning the rust off and just hitting the exposed area with some black rustoleum and a small paint brush. Will this do the trick? Thanks
 

·
Registered
Joined
·
625 Posts
So I installed a cb and mounted the antenna using a teraflex rear break light mount. The whole install went pretty easy. Except I had a little trouble tuning the antenna so from reading some other threads I figured out I needed to grind the powder coat off the mount (top & bottom). No problem there either got it tuned to about 1.3 on ch 20. But I guess I ground a little too much area around antenna an it started to rust within about 24hrs. Not sure what to do. Thinking about cleaning the rust off and just hitting the exposed area with some black rustoleum and a small paint brush. Will this do the trick? Thanks
Yea hit it with something to take the rust off then just some spray paint and you're good to go
 
1 - 2 of 2 Posts
Top