Jeep Wrangler Forum banner

CEL issue with aftermarket remote start solved - install notes for 13-18 Mopar remote start

983 Views 3 Replies 3 Participants Last post by  DiamondMox
So awhile back I had added an aftermarket remote start recommended to me - the MPC plug and play remote start. It seemed to do what it said, and then I had some odd random issues months later and it took awhile to connect the issue back to the remote start. Let me tell you - when dealers gripe and say to disconnect everything aftermarket during troubleshooting - sometimes it really does help. I work closely with a dealer here too, and this one stumped us for months and cost me a little money too as we went down a few rabbit holes chasing stuff unrelated.

The issue presented itself as a check engine light (CEL) with a few random U codes (body harness codes). These U codes led us to physically inspect harnesses for breaks, bad pins, dirt in connections, etc. It logically made sense, most were under the vehicle in the elements and I have miles on my Jeep too.

I wasn't having any performance issues with the codes being thrown though - and more codes would randomly come and go once we started digging in. At this point I knew the basics weren't the issue - I easily unhooked the winch power when we started this, and the other accessories were on the Apollointech switch panel or their own harness I built with a cutoff. So I disconnected those from the battery too, and we cleared all the codes and drove and retested again. I still had U codes coming up. It finally occurred to me that I had put the remote start in and we didn't test that part. The remote start won't work of course if there are any issues with a CEL, even low tire pressure. So cleared the codes again, tested, it worked. I didn't feel right about it though, so I went ahead and removed it and we cleared it all again.

Finally solved. That left the issue of why it happened. The only answer I got from Fortin was that sometimes the remote starts need to be reset too. Not promising. This would and could have easily been shop or dealer telling us to replace the entire body harness at the cost of over a thousand. It could have been chasing others stuff for weeks longer too - and we had spent a few months casually chasing this in our free time by now too. I reset the Fortin remote start, and it's not going back in my Jeep.

I still needed a remote start, I have dogs and like being able to run in at the gas station and leave it run for them for a few minutes and obviously don't want the keys left inside it. I bought the Mopar remote start kit at this point after researching it, they run around $250 today. This is THE Mopar stock kit - you need a Jeep with factory automatic transmission as usual, and remote keyless entry, and immobilizer from 2013-2018. the kit is -
Mopar 82213625AD

So there is a question on Quadratec's listing for this asking if this kit needs anything more to add remote start. Quadratec states this is to replace a malfunctioning existing remote start - THIS IS FALSE.

This kit is the kit to add remote start and is a complete kit. Anyhow, kit bought, kit installed - and let me say this too - it's not hard to install but it's not a simple plug and play kit either. You should be prepared and read everything before buying it - Quadratec does have the official install PDF on their listing you can read.

Before installing the remote start kit - unmarry any programming devices you have - this includes the Procal. Also fill your tires back up to stock pressure of 36 psi for now, it will save you headaches during install.
I use a Procal for the tire size, and the TPMS. I had issues I'll explain below.

I got the Mopar remote start installed - the only thing I have to note here is that Mopar cheaped out on the length of wiring for the hood pin, forcing it to cut across a corner. This really should have been caught before production - but it wasn't. I simply cut the two wires for the hood pin and soldered/heat shrunk a nice extension piece into it so I could tuck it with the stock harness and wrap it nicely.

When installing the WCM at the ignition - the easiest route is the remove the right side arm on the mutli-switch, leaving the harness connected, and just gently lay it on the top of the wheel column to access the bolt for the WCM mount.

So I got everything done, and programmed for the remote start and ran into a few issues.

First, the last step instructs you to drive to 35 mph to activate the remote start - but - if your TPMS is on, the remote start still won't work.

Second, the TPMS will be on even if you had a programmer, because you reset the computer during this install, it now is back to stock, and it won't program again with a code present. I tried programming with the Procal again, and it would fail. I had to go back, unmarry the Procal, fill the tires to 36 psi to get the TPMS light reset, and then remarry the Procal, and set the tire pressure back down and tire size back to where I need it. Then I could lower the air pressure in the tires again to normal driving psi.

Thankfully the Procal is forgiving enough that it would unmarry after I did the install, I'm honestly not sure if other programming may have an issue with that, so I highly recommend unmarrying them before doing the install for the WCM itself. You can split your days up doing this install though, and I did. One day I installed the hood pin and wiring harness under the hood. Another day I did the antenna unit behind the dash and had the keys cut (not programmed, just cut). The last day where we had these issues was the day to swap the WCM in and program everything.

Overall I'm very pleased with this kit. It's a Mopar product, so backed by Jeep, and because it's a Jeep product, it also will show up properly in troubleshooting methods down the road - no more unhooking an aftermarket remote start that was actually the cause of odd CEL codes. I hope this writeup clarifies a few things for the product and makes it easier for someone else to install too.

Quadratec link for product - PDF - Mopar 82213625AD Remote Start System for 13-18 Jeep Wrangler JK with Automatic Transmission
See less See more
  • Like
Reactions: 1
1 - 4 of 4 Posts
Interesting. I have the MPC remote start in my Jeep and has been there since late 2017 I think and I have never had an issue with it. My biggest complaint about it is that the range kinda sucks. I have to be pretty close to the Jeep for it to work. Oh well.
My Jeep could just be super picky too. There have been some oddball electrical issues over the years, I have seriously wondered if some could be the TIPM or ECU/PCM causing parts to fail or have weird issues. Everything tests normal though so..
I also installed the OEM remote start and can say that after programming the WCM, don't miss the step where it says to cycle the key twice. When I took mine to the dealer to enable the remote start, they tried and said they couldn't get it to work. I then talked to the tech and had brought these instructions in with me to the dealer and showed them to him and he saw that part and said his instructions in the service manual didn't have that line. He tried it again with the included instructions and blamo, it worked.
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.