Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter · #1 ·
Was wondering if anyone else has had something similar happen...

I was low on gas (probably a little less than a 1/4 tank left) and filled up last night. Afterward, I drove for about 1.5 miles and then I heard a chime, which caused me to look at my dash. My gas light was on and the needle of the gauge was pinned on "E". Additionally, my CEL was on too.

Since I had just filled up, I obviously wasn't out of gas on my 2015 JKUR with only 6,000 miles on it! I drove for a bit and the gas light went off and the level went back to full, but the CEL remained on. I know I tightened the cap properly after getting gas, but at my next stop, about 2 miles down the road, I opened the gas cap and re-tightened it as that sounded like the simplest reason why I was having issues. I have since driven it about 15-20 miles and the gas gauge seems to be working properly. After a few more ignition cycles, the CEL turned off too.

My question is, I understand how a loose cap could cause the CEL, but it seems really strange that the needle on the gauge would temporarily go to "E" along with the low fuel warning coming on. Has anyone else had similar issues?
 

·
Registered
Joined
·
8,968 Posts
I never heard of that as far as the gauge going to E with a low fuel warning, but JK electronics can be interesting. It does seem like it was gas cap related since once it was re-set it eventually cleared which it will do after driving for awhile and after a few ignition cycles. If the same thing happens again I think a trip to the dealer.
 
1 - 2 of 2 Posts
Top