Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I was going to check the ignition switch and I pulled the cover off to get access when I discovered a circuit that I am not sure about. It looks like a relay with two fuses on a makeshift wiring mess that is spliced into another circuit. I think it could be combination flasher circuit but I think that would be part of the loom and not a aftermarket wiring mess. The relay is 40 amp and the fuses are wound in tape. There is also a nylon connector on this circuit that is not plugged in but is labeled top and bottom #9
Help!
 

·
Registered
Joined
·
194 Posts
I was going to check the ignition switch and I pulled the cover off to get access when I discovered a circuit that I am not sure about. It looks like a relay with two fuses on a makeshift wiring mess that is spliced into another circuit. I think it could be combination flasher circuit but I think that would be part of the loom and not a aftermarket wiring mess. The relay is 40 amp and the fuses are wound in tape. There is also a nylon connector on this circuit that is not plugged in but is labeled top and bottom #9
Help!
Pics always help...but sounds like it could have been an aftermarket alarm that has been partially removed
 

·
Registered
Joined
·
3,513 Posts
Not factory. Get a schematic, see which wires are being tapped into. Others you might have to hand trace. Make a diagram.

With the amount of circuits in vehicles anymore, not really that easy.
 

·
Registered
Joined
·
194 Posts
Looks like an aftermarket alarm....If it's not causing any problems I would leave it alone,, or if it vexes you, you can do what Sparky suggests
 
1 - 6 of 6 Posts
Top