Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 20 of 242 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter · #1 ·
My 2012 has a chirping noise. I've had it since the first time the engine was good and warm and idling, and that's the only time I have it. It sounds like it's near the alternator.

I took it to the dealer and it turns out to be the water pump bearings. "NEW WATER PUMPS ARE ON 'NATIONAL BACK ORDER'". They can't fix it for a couple of weeks

It sounds like I'm not the only one with a chirping water pump, but I didn't find an established thread.

It shouldn't make a difference (like the whistling on 2-doors), but, FYI, it's a 4-door Rubi.
 

·
Registered
Joined
·
625 Posts
I get the occasional chirp, but I had assumed it was from the suspension. Definitively under the hood area though.
 

·
Registered
Joined
·
8 Posts
Same chirp here

I have a 2012 Warngler and it only has 7k miles and I am getting the chirp from the engine. The brakes are also squealing. Anoying as heck to have this all at one time. Got a recording of the noise I wish you guys couild listen to but dont think I can upload it here. Engine noise at idle and it gets loud then fades away some, and then comes back...etc
 

·
Registered
Joined
·
26,921 Posts
When did water pumps start coming with bearings?
Water pumps have always had sealed bearings for the shaft going thru the pump that turns the impeller.
 

·
Registered
Joined
·
6,146 Posts
I had the same problem and they replaced it.

It was a pain because at first it didn't always make the noise, so took 4 trips to the dealer. One of the times they replaced the wrong part too, then figured it out.

I made a video of it (mostly for the sound).

Water Pump Noise - YouTube
 

·
Registered
Joined
·
188 Posts
Discussion Starter · #9 ·
very late 2012

Just out of curiosity, what is your build date?
sorry I didn't see this earlier. I'm out of state and don't have my jeep stuff with me.

The jeep was built very late in the 2012 build year, something like just a couple of weeks before it was too late to order one from the factory because they were tooling up for 2013.

When I get home I'll try to look it up (from the build sheet?) and get back to you.
 

·
Registered
Joined
·
570 Posts
Thanks to Blastek for pointing out this thread to me. I just took my 2013 JKR in today for the exact same noise heard in the linked video. I've only had it for seven days brand new off the lot! :banghead:
 

·
Registered
Joined
·
12 Posts
Thanks for the video. I was idling waiting to pick up my son and had the radio off and heard something and was wondering what it might be. Came back and opened the forum and this was on the front page. Will have to have dealer check it out. Thanks!
 

·
Registered
Joined
·
570 Posts
Got my 2013 JKR back this morning and they said it's the water pump and it's on national backorder.

The description of their work says "water pump seal noisy". They gave me the Jeep back and will call when part is in.
 

·
Registered
Joined
·
6,146 Posts
Got my 2013 JKR back this morning and they said it's the water pump and it's on national backorder.

The description of their work says "water pump seal noisy". They gave me the Jeep back and will call when part is in.
Took them about 2 1/2 weeks to get the part for me a few months ago. It was such a relief to have the noise gone.

Went it started with me, it was occasional which was the time when it conveniently wouldn't make the noise when I brought it in. After a few months it was making the noise about 90% of the time.

Got annoying on the trails with people asking 'what's that noise?'... :banghead:
 

·
Registered
Joined
·
478 Posts
Interesting, glad I took the time to read this. Very appropriately made title to the thread. I've had that annoying noise on and off, too. I thought it was the alternator perhaps working extra hard to charge my dual batteries and needing a little belt dressing, but I knew that sounded a bit absurd for a newer vehicle with a 160A alternator.

Thanks for the video! That really sealed the deal for ensuring it was the same noise. I would call it more of a "squeeling" than chirping noise, but that's what's great about a video, since we can all describe sounds differently. Will have to take mine in soon!
 

·
Registered
Joined
·
771 Posts
:banghead:

reared its ugly head today.

4000 miles 2012, just today echo'ing off the wall weird electronic sounding cycling alarm kind of deal. Stopped and mad dog chipper/chirping going on from the front by the radiator. Stopped after switching off and starting again.

Hoping its the aux auto tran cooler doing its job, just did a 3 hour non-stop run.

Will check it out again with more time on hand.
 

·
Registered
Joined
·
771 Posts
Taking it in today. Came back in less dramatic fashion. Let me update the signs in case anyone else comes across it in the future

1. high speed marathon 3 hour run, @ idle the thing was chirping squawking shrieking like nothing else. Really loud, didn't even have to get out. Sounded like a muted alarm system cycling. Switched off, waited less than 30 seconds restart nothing.

2. Normal daily driving in the city nothing.

3. 2 hours stuck in traffic stop and go. At idle and have to get out, slight whine going on, increases with revs.

Obviously something related to heat or engine on for a long time etc.

Not really concerned with what it is so long as its fixed and its under warranty. Its the trip to the dealer and trying to explain it and since its not evident unless under usage like above. Can see them dragging it out for a week trying to figger it out. That's the pain in the azz :banghead:
 
1 - 20 of 242 Posts
Top