Jeep Wrangler Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello, I have a 1965 CJ5....134 c.i. 4 cylinder engine

I have put new plugs, wires, distributor cap, rotor, points, and condensor.

Took the valve cover off to make sure all rockers are working propery.

Good compression.

Timing is good, firing order is correct.

The jeep has a slight miss at idle and under acceleration.

The carb has onlt one screw for adjustment...moved it both ways.

After all of this is still runs poor with slight black smoke and has rich fuel smell when running...

Any ideas that I might have overlooked?
 

Attachments

·
Registered
Joined
·
1,738 Posts
Stuck float, down probably..... or saturated...... possible needle valve grooved/seal fallen off.

gasket issue letting fuel into carb when not supposed to......

Vacuum leak......

idle screw adjustment....

does it only do this when cold????? possible stuck choke..... OR choke not closing....

and the list goes on.....
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
I agree with the carb issues.....I will just have to dig in a little more...I'm not giving up yet..

Thanks Harleydragon and bc3 jeep
 

·
Registered
Joined
·
1,180 Posts
good suggestions from bc3

Check out forums at earlycj5.net
Lots of guys with Hurricane 4 experience & info
 

·
Registered
Joined
·
300 Posts
That carburetor is very simple and easy to overhaul. Often the float needs replaced as well as the needle and seat. Especially if it has been not used for periods of time.

Once you study the overhaul proceedure and take it apart it all becomes simple and it will never perplex you again.
 

·
Super Moderator
Joined
·
7,770 Posts
Another vote for a bad carb. I'd consider a rebuild if a good cleaning and adjustment doesn't resolve the problem.
 
1 - 8 of 8 Posts
Top