Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I had a clogged winshield washer pump due to some orange bug removing premixed washer fluid.

What I did was take a water hose and put it in the windshield washer reservoir and turned the water on.

Unplugged the hose from the nossle on the hood and took a can of compressed air with no staw. Held the hose up to the nossle and pushed air through it for about a second or two, enough to see bubbles coming through the reservoir. Did that about 20 times. Every 4 to 5 pumps I pushed water through the pump via the wiper control lever.

Once I was sure the clogg was removed, I siphoned out the water and put the tride and true blue washer fluid with about a half bottle of 91% isopropyl rubbing alcohol in the reservoir.

Hope this helps someone out there.

Also a side note keep your compressed air straight up and down, if you do not, you can get liquid coming out that will give you frost burn and destroy your winshield washer tube.
 

·
Registered
Joined
·
34 Posts
You're going to have the build-up again, I'd be willing to bet. I had the same issue and it required actually popping the pump out of the reservoir (very simple to do) and scraping the filter clean, then blasting it with compressed air to break up what jammed into the screen. You cleared enough passages in the screen for it to function properly, but if you didn't remove all the bacterial growth it can readily regenerate and block it up all over again.

Hopefully you got enough of it that it won't be a problem, but if it does happen again, just pop out the pump and clean it directly, then spray fresh water into the reservoir until it's all hosed out and pop the pump back into position.
 

·
Registered
Joined
·
84 Posts
I am dropping my 13 JKU off at the dealer Monday. The reason? I filled up my reservoir a couple of days before leaving for the beach 4th of July week. Left the Jeep at home (wife refused to drive the "gas hog"). When I returned, I went for a drive, hit the windshield washer, nothing. Thought this was odd as I remember filling it but didn't remember using it. So my buddy comes over to help trouble shoot. He crawls under the Jeep as I pour a gallon of water in the reservoir. It's gone in under a minute. It sprays the front but not back. I had my drivers window down and was squirting the back glass and I could hear water spraying. Opened my door and pulled up the floor mat. There it was, about a gallon and a half of water. Even the blue that I filled up with two weeks earlier. So they are gonna fix it and detail it. The hose going to the back glass either burst or came undone. So if you have this problem check under your mat for the water.
 
1 - 5 of 5 Posts
Top