Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
okay so i was driving my 2000 jeep wrangler Sahara and randomly my car starts shaking hard af. i pull over check everything out and everything seemed fine. i start it up and notice all my gauges stopped working and my radio wont come on. The back lights still work on the dash and the seatbelt light came on but the arms on the gauges wont move. What could be the problem ?
 

·
Registered
Joined
·
148 Posts
okay so i was driving my 2000 jeep wrangler Sahara and randomly my car starts shaking hard af. i pull over check everything out and everything seemed fine. i start it up and notice all my gauges stopped working and my radio wont come on. The back lights still work on the dash and the seatbelt light came on but the arms on the gauges wont move. What could be the problem ?
Gauge problems = bad cluster connection. Pull it apart, check to see it there's any corrosion on the connector. Twisting the contact pins is one recommended fix.

Some people recommend applying dielectric grease. I guess that's OK if you have water infiltration issues and want to try to seal it and/or displace water.

I got conducting grease in a syringe applicator. I squirted a little dab onto each pin. My symptom was poor contact, not water. Conducting grease improves that. No problems since I did that.

Sounds like maybe you have two problems - shaking, which may be what leads your cluster to come loose.
 

·
Registered
Joined
·
148 Posts
so you did have this problem before?

My cluster problem showed up when the Jeep was about 6 years old; it would happen when I was driving on rough roads, banging around.

I've not had it since I pulled the cluster, twisted the pins and gave them a touch of (conducting) grease.
 
1 - 4 of 4 Posts
Top