Jeep Wrangler Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I own a 2012 jeep wrangler sport with a 6speed manual. My clutch slave went out and I'm trying to replace it but for the life of me i cant get it out of my transmission. I got both bolts off and the hydraulic line disconeted and every time i try and pull on it nothing happens. Ive even gone as far as putting a screwdriver up there and trying to pry it off but nothing. What can I do to get it off without dropping my trans? Help please.
 

·
Retired Moderator
Joined
·
103,565 Posts
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
Joined
·
876 Posts
Well that is odd. I would say you simply have a tight fit issue. I did mine and don't remember having such an problem. Just used the bolts to reinstall. Can you get maybe a putty knife between the slave and the trans? Just asking but you've grabbed a holed of it and really pulled and up and down? Any sign of gasket material?
 

·
Registered
Joined
·
306 Posts
It should come out easily and dropping your trans wouldn't help anyway, unless maybe the arm broke or somehow got caught up. Since you've removed the two nuts, i would continue prying it out. Be careful and give it a few easy whacks with a rubber mallet.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Well that is odd. I would say you simply have a tight fit issue. I did mine and don't remember having such an problem. Just used the bolts to reinstall. Can you get maybe a putty knife between the slave and the trans? Just asking but you've grabbed a holed of it and really pulled and up and down? Any sign of gasket material?
I appreciate the help. Last night I was able to get it off it was just stuck with gunk after a lot of PB blast and a flat head i was able to wiggle it off the studs.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top