Jeep Wrangler Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
Ok we went wheeling yesterday for about 3 hours. Got stuck once in a soupy deep hole but got pulled out no biggy. We left the park and made it less than a quarter mile and check engine light comes on and she goes into limp mode. Soon it starts overheating as well. I baby it home stopping multiple times to cool down. At one point I also got a hot oil light. Got her home and cleaned it up as best I could with a garden hose. Pulled the thermostat because I figured that was why it was overheating. Filled it with water and she still heats up but takes a bit. Think that might be because no thermostat and no dex cool in it? Shes still in limp mode and code P1731 comes up. Tried resetting it multiple times and nothing works. I'm at a loss here and NEED her fixed. Any help?

2012 JKU auto, 37" tires, bully dog programmer.
 

·
Premium Member
Joined
·
488 Posts
P1731-INCORRECT GEAR ENGAGED

looks like you should check your ABS and speed sensors and maybe the transmissions solenoid.
 

·
Registered
Joined
·
88 Posts
How deep was it? You may have to flush the transmission if you got in water deep enough to get into the transmission fluid. Water mixing with the fluid gets all foamy and could be messing with the gears. You may want to check your diff fluid while you're at it too, but I doubt that would cause the CEL.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #4
Update: went out yesterday and realized the radiators were full of mud. Hosed them off for awhile and topped the radiator off with water. Drove 5-6 miles and although she heated up a bit more than normal it didn't overheat. Think it's getting hotter because it's straight water and no dex cool? Waiting on new thermostat to come in before I put in $45 in antifreeze.

Reset check engine light but it still came back on and was in limp mode. Won't shift past 2nd gear.

The water/mud was pretty deep. Almost up to the hood. I went straight in, down and realized how deep it was threw it in reverse and backed most the way out. I checked the trans fluid and it doesn't seem to be contaminated at all.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #5
I did spray the heck out of the rear where the speed sensors are. Might have to pull the wheels and check them. Not sure how to check the trans solenoid or where it's at? Been researching a lot and some people with this code say it was their valve body. $800 is a steep price to pay for a guess though.
 

·
Registered
Joined
·
4 Posts
I have the same issue please someone help, i went mudding yesterday and now my jeep is on limp mode with the check engine light code p1731, any help would be appreciated plz
 

·
Registered
Joined
·
1 Posts
I have a 2015 wrangler sport unlimited ....found out its got limits ...i am also having the same problem ...wont shift past second gear .....or it stays stuck in 3rd ....will not shift manually either...please advise me how the issue can be corrected ..
 

·
RETIRED MODERATOR
Joined
·
47,305 Posts
I have a 2015 wrangler sport unlimited ....found out its got limits ...i am also having the same problem ...wont shift past second gear .....or it stays stuck in 3rd ....will not shift manually either...please advise me how the issue can be corrected ..
 

·
Premium Member
Joined
·
549 Posts
I have a 2015 wrangler sport unlimited ....found out its got limits ...i am also having the same problem ...wont shift past second gear .....or it stays stuck in 3rd ....will not shift manually either...please advise me how the issue can be corrected ..

Did you pull codes? Did you get the P1731?
 
1 - 9 of 9 Posts
Top