Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My 2006 Rubicon has a cruise control problem. The CC works for about 20 to 25 miles then the green cruise light goes out and the CC stops working. After I stop for a few minutes, it will work fine for another 25 miles or so. Any help appreciated!
 

·
Registered
Joined
·
278 Posts
The CC system is operated via a vacuum line. Check your lines for leaks, might just be a slightly loose boot. I had the same issue in my 2005. Does yours by chance have any issues with the vent switch? Mine had a tendency to stay on defrost until I found the leak because it's on the same vacuum line as the CC.
 

·
Registered
Joined
·
727 Posts
Not sure if this would help you. Mine acted funny twice and without even realizing I I fixed it twice! Basically I realized that it came back to life after disconnecting and reconnecting my battery. Give it a try: it's only wierd if it doesn't work.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I will check the vacuum line for leaks. I have not had any issues with the vent switch. It is strange issue, the CC works for 25 minutes or so, then shuts down.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Cruise Control

The problem with the Cruise Control was the brake pedal switch, I picked one up and put it on and the cruise works great. I conducted an ohm test on the old one and sure enough, it was bad. Thanks for all the great advice, this is great forum. I found detailed instructions on how to find and replace it, only took fifteen minutes. Thanks Jeep Forum!
 
1 - 7 of 7 Posts
Top