Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
On my 92 the dash lights are opposite. When brights are on the dash light is off. Turn signals on dash are lit but when I turn them on to turn they flash. 4x4 light is on when in 2h off when in 4wd. Is this the way it is supposed to be?
 

·
Registered
Joined
·
76 Posts
Something is definitely wrong, its a short somewhere. I have no experience with Jeeps as I'm new myself, but I no that is not how its supposed to be.

I have a problem with my right turn signal, sometimes when I turn it on, it lights up and stays on, other times it flashes normally.

I also have a problem with my radio wiring..
Its wirined in with a wire harness and hooked up properly, but when I turn the truck of the radio shuts off and doesn't keep memory. Then yesterday it wouldn't turn back on, so I pulled it out and everything looks fine. All the fuses are good. So out of curiosity I hooked the power(red) and battery(yellow) wire to the battery wire in the dash and it turns on and keeps memory. But I have to press power to turn it off when I get out now.
 

·
Registered
Joined
·
119 Posts
I belive the yellow wire is for constant power supply (this will help it keep the memory). While the red is for igniation. Or I may have that flip floped...LOL
 

·
Registered
Joined
·
76 Posts
I repeated the exact same thing I said. My point was that for no apparently reason the ignition(power red) stopped working. But the fuses are all good.
 

·
Registered
Joined
·
325 Posts
joshpowell16 said:
Something is definitely wrong, its a short somewhere. I have no experience with Jeeps as I'm new myself, but I no that is not how its supposed to be.

I have a problem with my right turn signal, sometimes when I turn it on, it lights up and stays on, other times it flashes normally.

I also have a problem with my radio wiring..
Its wirined in with a wire harness and hooked up properly, but when I turn the truck of the radio shuts off and doesn't keep memory. Then yesterday it wouldn't turn back on, so I pulled it out and everything looks fine. All the fuses are good. So out of curiosity I hooked the power(red) and battery(yellow) wire to the battery wire in the dash and it turns on and keeps memory. But I have to press power to turn it off when I get out now.
With your turn signal, replace the flasher. It is a sign its going bad. It's on the fuse box under the driver dash, it's the cylindrical silver one.

If your little green arrow is only solid, and not flashing, your blinkers are only solid, and not flashing.

I had the same problem, and then it got worse to where it didn't flash at all. I replaced it and it was immediately fixed.
 
1 - 9 of 9 Posts
Top