Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 15 of 15 Posts

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #1 ·
So I have this weird clicking sound coming from the glovebox area when either defroster setting is engaged. The defroster seems to be working flawlessly, but this darn clicking sound is annoying me. Any thoughts? Thanks.
 

·
Registered
Joined
·
570 Posts
Mine sucked up a piece of plastic shopping bag. Removed the fan to investigate the noise and there it was.
 

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #4 ·
It clicks like every 3 or 4 seconds when the floor/def or regular def is on. It happens even when the fan is not on. Thinking that it is not the fan for that reason.
 

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #6 ·
OK...One more bump and then I'll assume people don't know. Thanks!
 

·
That WF guy.
Joined
·
21,557 Posts
It clicks like every 3 or 4 seconds when the floor/def or regular def is on. It happens even when the fan is not on. Thinking that it is not the fan for that reason.
If it is doing it with the fan switch selector off...then it wouldn't be the blower as it is off.

There are relays a resistors behind the glove box location. Have you pulled the glove box off and tried to pinpoint a closer location of the issue?


If it only makes the sound as you put the fan location selector to defrost or the floor...I would have to say you hear the blend door moving into it's posistion for that setting.

Can you make a video of the issue sir?
If you can, please leave the engine off so to better hear please.

:wavey:
 

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #8 ·
Happens when the fan is off. I'll try the video thing. However, I'm not sure if the sound will happen when the engine is off. Thanks for the tip!
 

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #10 ·
OK....Here it is. I had to have the engine running to get it to work. I think that you may be onto something with regards to relays, because it sounds like something turning on and off behind the glove box. Listen carefully and you should hear it 4 times throughout the course of the video:

http://www.youtube.com/watch?v=ITV5EqkzuoM
 

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #12 ·
OK cool. So it sounds like something normal that I don't need to worry about. Thanks so much!!:)
 

·
That WF guy.
Joined
·
21,557 Posts
Well I just went out to check in mine...here is the verdict.

With the engine off you get no "Vacuum", but you do to the relays....so if the key is on but not the engine and you DON'T hear it...it is not a relay....but it is a vacuum. :D

I popped the glove box out and pulled the kick panel under the passenger dash. I found it. :p

Vacuum actuator. Just doing it's job. Your is a hair bit louder than mine but the same.

Nothing to worry about. :)
 

·
Brewing, Skiing & Jeeps..
Joined
·
549 Posts
Discussion Starter · #14 ·
That is a huge help dude. Thanks alot!!!
 
1 - 15 of 15 Posts
Top