Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
162 Posts
Discussion Starter · #1 ·
Hi everyone
I know this has nothing to do with Jeeps but I know there are some mechanically very smart people on here and I was wondering if you guys could maybe help me. My Yamaha ttr 230 dirtbike recently started not running right. It will idle ok, but if you rev it up at all it sounds like its on choke and starts backfiring. I know its not the carb. It did it once, and i killed it and started it back up and it was fine. But now it wont go back to normal. It was running great before this; never had a problem with it. Im thinkin its either timing or something electronic with the spark. Thanks
 

·
Registered
Joined
·
1,610 Posts
How long was it sitting before you started messing with it again? My TTR 225 does this every time it sits longer than a month and he Carb get clogged up with the fuel that's starting to break down.
 

·
Registered
Joined
·
24 Posts
Check your fuel/air ratio screw. It's a small either recessed flathead screw or an extended brass screw on the front of the carb. Start with it all the way screwed in then bring it out 1 full turn. Adjust slightly after the bike is fully warmed up and twisting the throttle. Find the sweet spot where it rolls on smoothly. Do not take it out beyond 2 1/2 turns. If it needs this u need to re-jet your main jet.

Also check out thumper talk for more info.
 

·
Registered
Joined
·
2,585 Posts
Did you actually take a small piece of wire and poke through the main jet to ensure it is clear?

Check to make sure no stator wires are worn through and grounding out anywhere.
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #5 ·
Y'know, it was a little over a month since its run (the longest its ever sat). I guess I was wrong and it could be the gas. Right when you think you know something about mechanics. Thanks for the help Ill check it out
 

·
Registered
Joined
·
568 Posts
Just to give my 2 cents. I've had all my bikes sit for over a month with the same gas but they fire up and run fine. A long time a go my TT-R 125 did the same thing, took the carb apart cleaned it and put a new air filter in. ran fine after that. Sounds 2 lean too
 

·
Registered
Joined
·
10,137 Posts
I owned two TTR-125s for my sons. If they sat for awhile, they would get a yellow-green film in the carbs. I was told by the motorcycle shop that they were seeing this problem frequently since the gas companies increased their gas/ethanol mixture to 10% in 2011. The film clogs the jets and can also make the float stick. I never had this problem in the past with my dirt bikes or street bikes.
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #8 ·
I figured it out finally. The battery was completely dead and was somehow affecting the spark. Replaced the battery and everythings doing fine
 
1 - 8 of 8 Posts
Top