Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter · #1 ·
I've had a wobble problem for awhile now. At first it would happen anytime I was going between 45 and 50 mph and hit a rough patch in the road. I've had the tires rebalanced and I replaced my sway bar ties (pic included below of the old ones). Now it only occurs under braking as I fall through the 50-55mph range. I've done a dry steering test. Everything appears to be tight, no wiggle or play. I've inspected every bushing I can lay eyes on. My lower control arm bushings do show some signs of dry rot around the edges. I'm completely lost at this point. Where do I go from here?


 

·
Registered
Joined
·
359 Posts
Discussion Starter · #3 ·
Appears the axle end bushing on the track bar does have some play in it. Somehow I missed that bushing during the first dry test :banghead:
 

·
Mostly old school..!
Joined
·
12,149 Posts
Appears the axle end bushing on the track bar does have some play in it. Somehow I missed that bushing during the first dry test :banghead:
There shouldn't be any movement in the track bar ends and that is the most common source of wobbles.
 

·
Registered
Joined
·
359 Posts
Discussion Starter · #5 ·
Alright, I finally got a bushing shipped here and installed. The old one was a little bit ovalled but not horrible. I've had the new one installed for 2 days and have yet to be able to reproduce the shaking under and circumstances! :bop:

So happy to finally have this problem fixed!
 
1 - 5 of 5 Posts
Top