Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
Up til a couple weeks ago whenever I would open the driver's door after parking and turning off my 2014 JKU the electrics (radio, dash lights, etc) would immediately go off...but now I randomly have a short delay, maybe a second at most, when the electric items stay on after the door swings open.

It's most evident if the radio is playing; where normally a song would cut off the instant the door opens, now it occasionally lingers a bit before shutting off.

Anyone else seen this, perhaps know what signal (digital, mechanical) is telling the vehicle that the door has opened?

Seems like it might just need a little lube somewhere. Unlike 'normal' vehicles our Jeeps don't have a switch on the door that pops in and out to indicate opening/closing state...I'm wondering if there might be something in the ignition switch that is sticking...

Thoughts?

thanks,

Commo
 

·
Registered
Joined
·
2,240 Posts
I'd start by unplugging the door harness and hitting the contacts with contact cleaner. I think the switch is in the latch mechanism itself.

Sent from my SM-T550 using Tapatalk
 

·
Registered
Joined
·
348 Posts
Up til a couple weeks ago whenever I would open the driver's door after parking and turning off my 2014 JKU the electrics (radio, dash lights, etc) would immediately go off...but now I randomly have a short delay, maybe a second at most, when the electric items stay on after the door swings open.

It's most evident if the radio is playing; where normally a song would cut off the instant the door opens, now it occasionally lingers a bit before shutting off.

Anyone else seen this, perhaps know what signal (digital, mechanical) is telling the vehicle that the door has opened?

Seems like it might just need a little lube somewhere. Unlike 'normal' vehicles our Jeeps don't have a switch on the door that pops in and out to indicate opening/closing state...I'm wondering if there might be something in the ignition switch that is sticking...

Thoughts?

thanks,

Commo
I don't think it is going to be the ignition switch. I believe the behavior is different when the door is plugged in vs not (because the door is never 'open' or 'closed' when it isn't there), but off the top of my head I'm not sure what the 'no door' behavior is, probably what you are describing.

So make sure the door harness is plugged in tight, check the wires, and check the door switch (I believe it is in the latch assembly in the door).
 

·
Registered
Joined
·
143 Posts
Discussion Starter #5
I pulled the door harness and gave it a good blast with contact cleaner. I only worked the one end as I didn't want to take the door apart to get to the other end of the harness. I guess that could be the next step if the problem worsens

I also cleaned a little crud out of the door latch.

For grins I also put a shot of lock lube in the key opening and also a shot of dry lube around the barrel of the ignition switch, as when I first got the Jeep (2014) the barrel sometimes stuck in the pressed-in position when I removed the key, giving similar symptoms.

Just a few stop/starts since then but the problem hasn't recurred...yet. Will let you know.

Thanks,

Commo
 
1 - 5 of 5 Posts
Top