Jeep Wrangler Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Would greatly appreciate if someone could help me out.

The wiring for Bank 1, Sensor 2 ripped out somehow and tore the body side connector with it.

I have a new NTK 02 sensor since the old one's wiring tore up completely and i'm having trouble matching up the wires to what i can find in the FSM.

I checked the FSM but can't seem to understand where these wires would match on on the NTK sensor. Am i looking at the wrong diagram on the FSM?





 

Attachments

·
Registered
Joined
·
3,686 Posts
Those colors look like they match with the FSM. The FSM colors are for the harness side of the connector & often a pigtail to a sensor has different color wires so you can’t expect them to match up. You need to match the pin #s which hopefully are marked on the plastic connector. If not or if the connector is too damaged you should be able to go the connector pin outs chapter (8W-80-36) & see how the pins line up by # & color for the harness side. It should then correctly plug into the pigtail side. Use the “except export” to match the colors.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for pointing out the FSM page.

I do not have the connector so i have to match up the colors & pin # to the NTK 02 sensor side.

However, my harness colors don't seem to match up? Am i not looking at the right sensor on the FSM? Or possible someone before me mixed up the sensor harnesses?

NTK- Jeep harness side - Purpose
Black ---> Tan/White Signal
Grey ---> Black/Light Blue Ground
White ---> Black? Heater?
White ---> Black/Orange? Heater?

 

Attachments

·
Registered
Joined
·
3,686 Posts
If I understand correctly, what you have is those 4 wires (pictured) & a new O2 sensor with a wiring pigtail that has a connector on the end.

In the photo from left to right it looks like you have black/light blue which would be pin 3, tan/white which would be pin 4, the next 2 are hard to tell from that angle but look like maybe orange/dark green which would be pin 1 & maybe brown/white (can’t see a tracer color) which would be pin 2.

If that is correct so far then you should be able to position the wires into the pigtail connector to match the pin out diagram in the FSM.

If the colors for the last 2 are different (the FSMs are not always correct), one of them should have constant 12v power (from fuse 16 in the PDC) which would be to pin 1 & the other should be grounded when the engine first starts to activate the heater only for a short time so may be hard to test but if you can get the other 3 figured out you will know where the last one goes. And, as I read the diagram it appears that the heater wires could be either way since they only pass current through the heater element in the sensor so polarity should not matter which might explain why 2 sensor wires are the same color.(?)

Everything else I find indicates exactly that. Get the signal & sensor ground correct & the heater 2 do not matter (no polarity).
 
1 - 6 of 6 Posts
Top