Jeep Wrangler Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
Parked my 2015 jkus, everything fine. Came out an hour later, and interior lights, dash lights, AC, turn signals don't work. Windshield wipers are on, non-stop. Can't turn them off. 430 head unit works fine. Very odd. Any ideas or suggestions? Thank you.
 

·
Registered
Joined
·
1,373 Posts
get it towed to the stealership you should still be covered by the bumper to bumper warranty at this point have them sort it out
 

·
Registered
Joined
·
783 Posts
Have you been driving rough roads. Check for loose fuses in Eng Compartment fuse box. And hows the Instrument Panel Self Test when you insert the key to the on position. Do All the lights come on, test and turn off.
 

·
Registered
Joined
·
783 Posts
No rough roads. No lights come on at all on the dash.
So youre saying that when you insert the key to the ON position or START that the Jeep doesn't do the Systems test. All the Fault and Warning lights should come on and do a test and then turn off. Were you hit by Lightning possibly and dont know it. LOL. Better yet, were you recently in an Electrical Storm with lots of lightning.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #11
No storms. Had only been parked at my office for an hour. Everything worked fine then. NO lights come on at all, except for the 430 head unit. The wipers continually run, no matter what I do to the controls. I cycled the ignition on and off a few times. Set and unlocked the doors a few times. Nothing. At least the headlights work, although I can't do bright/dim.
 

·
Registered
Joined
·
92 Posts
It's probably the clock spring if your steering column got wet, it handles all the electronics that go through the column. There are write ups on how to change it or diagnose it better.


Sent from my iPad using Tapatalk
 

·
Super Moderator
Joined
·
22,032 Posts
I would first do as suggested and disconnect the battery positive and negative and touch them together for a minute. If that does not work call the dealer for a tow.
 

·
Premium Member
Joined
·
2,052 Posts
As a few more clues emerge it's sounding like a TIPM problem. My 15 JK had some similar issues at 8k miles. The dealer checked all the connections and it seemed to be OK for a week or so, eventually replacing the unit.
 

·
Registered
Joined
·
1 Posts
Same issue as the other jeeps problem is no one has any answers apparently not even the dealership. Is this a close my eyes and it will disappear thing? We have a 2010 wrangler sport it is sitting in the driveway same issue starts headlights work but cant get it in gear and the dash lights don't work . It has not killed anyone so jeep is not going to do anything to them it does not exist
 
1 - 18 of 18 Posts
Top