Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey all,
So I've read as many forums as I could that related to my problem with (drum roll) no blinkers, radio, or wipers. Cleaned the old ignition switch like someone suggested; no fix. Bought a new switch and still nothing.
What happens every once in a while when I start to play with the blinker lever, the left blinker comes on, but doesn't blink. It only comes on for about 3 seconds. Last night, I was messing around with the steering tilt and that caused it to come on and blink a couple times. I haven't been able to get it to happen again. Also, only the left blinker ever tries to come on. Radio used to show time, lately there's been nothing from it. Wipers don't even try to come on. When I mess with the turn signal lever, I can hear the relay clicking.
I am really stumped and also I'm not good with electrical stuff. Any help would be greatly appreciated.
 

·
Registered
Joined
·
15,694 Posts
Did you check the engine to tub ground that goes from back of engine to the firewall


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15,694 Posts
Look at base of underside of hood and see the ground strap bolted there follow that strap to bolt on firewall

From that same firewall bolt a ground strap goes to back top engine
Make sure strap is present intact and has clean tight ends


Sent from my iPhone using Tapatalk
 

·
Retired Moderator
Joined
·
100,678 Posts
:welcome: to the Forum..:wavey:
 
1 - 6 of 6 Posts
Top