Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have read plenty of these same problems but can't seem to find an answer...

I own a 2008 4dr JK (2WD... be nice now). I am headed down the road and all of a sudden the horn starts blaring, windshield wipers & fluid start, and the door locks are going crazy. I pulled over, disconnected the battery and tried to figure out what the heck was happening. After about a 1/2 hour of searching my phone for answers (found a ton of the same problems) and not finding any straight answers, I decided to reconnect the battery and drive it home.

So, now that I am in the place where others I am sure have dealt with this problem hang out, can anyone give me a straight answer on what I need to do to get this problem resolved?

Thanks for the help.
 

·
Premium Member
Joined
·
7,467 Posts
Sometimes a battery that is starting to fail can cause weird electrical issues. Also, check that both battery terminals are tight. Take a wrench to them, don't just try wiggling them with your fingers.
 

·
Registered
Joined
·
118 Posts
I agree with RoadiJeff low voltage or a battery going through a cut-off cycle will cause some weird electrical issues.

I've come across people replacing relays in the parking lot because they didn't know it at the time but their battery was dead and the low voltage was making all of the relays in their engine bay PDC click on and off like crazy. I put jumper cables on it and all the clicking stopped however the battery was too far gone to even take a jump.

Also have you made an electrical modifications to the Jeep?
 

·
Registered
Joined
·
2,105 Posts
I had a rally lights headlight box grounded to the screw clamp and it became loose and caused the initial start process. Ding ding and all that. Check the ground first and the battery second.
 

·
Registered
Joined
·
1 Posts
I have a 2009 Jeep Wrangler and The other day I was driving home and all of a sudden all of my interior lights, dashboard lights, warning lights and wipers came on. Nothing was turned on. It was strange. It stopped so I didn't think anymore about it. The next day the same thing happened and this time it didn't stop. I checked and my coolant and oil was low, so I filled them. Still nothing. Hubby ended up buying a new battery and installed thought this worked drove it for about 20 minutes and started doing it again. Oh and the infamous NO BUS light is on. I have tried everything does anybody have any ideas. Hubby also took it and had it hooked up to computer and nothing showed. HELP!!
 
1 - 5 of 5 Posts
Top