Jeep Wrangler Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
420 Posts
Discussion Starter #1
Ok so this evening driving home HEADLIGHTS ON I noticed that when I put the LEFT blinker on it worked fine, but when I put the RIGHT blinker on the arrow on the dash would not blink would just stay solid light. So I thought maybe I had a bad bulb. After parking the car i checked the left side lights they all worked inluding blinkers. the right side everything worked but front and back blinkers. "headlights on" I couldnt have 2 bad bulbs. so I turned the headlight off and checked the left side blinker again and checked out ok and then checked the right side blinker and not only the blinker works but the left side blinks as well...ALSO when I have the headlights OFF the dash lights come on when I step on the brakes??? ANybody been through this or have any ideas???? IS IT A MAJOR FIX???

THANKS FOR THE HELP IN ADVANCE:banghead:
 

·
Registered
Joined
·
205 Posts
Time to start chasing wires. I'm in clarkkent's camp that there is a short somewhere.

Do yourself a favor and look up the wiring schematic for the entire lighting circuit. This will give you some direction as you begin your search.
 

·
Registered
Joined
·
420 Posts
Discussion Starter #6
I spoke to a guy at a jeep dealership. He believes also it can be the multifunction switch. Dealership wants $250.00 for the switch.
Autozone has one for $80.00 "DURALAST"

Thinking about switching this part out, and the issue with the brake pedal causing the dash light to come on could be a ground somewhere...I will update this as I go along. Thanks guys.
 

·
Mostly old school..!
Joined
·
12,149 Posts
Your brake light circuit also feeds through the multifunction switch so it could be part of the same issue.
 

·
Registered
Joined
·
420 Posts
Discussion Starter #9
Ok so I purchase a new multifunction switch. slap the sucker on and ........it got worse. Now i have no blinkers no brake lights no hazards no reverse....WTF ??? I got headlights, high, fog, and dash what gives. I am almost driving to the dealer tomorrow and say here fix it pleaseeee lol
 

·
Registered
Joined
·
1,110 Posts
Ok so I purchase a new multifunction switch. slap the sucker on and ........it got worse. Now i have no blinkers no brake lights no hazards no reverse....WTF ??? I got headlights, high, fog, and dash what gives. I am almost driving to the dealer tomorrow and say here fix it pleaseeee lol
You forgot to swap the relay that was attached to the original switch. The instructions included with your new switch instruct you to do that.
 

·
Registered
Joined
·
3,087 Posts
If the new switch doesn't fix it, I would put the old one back and try this:

Take off each front/rear light assembly off and inspect and clean any corrosion in the bulb socket and where it screws into the tub. Those light assemblies are self grounded to the tub and sometimes corrosion will cause turn signal issues.
 

·
Registered
Joined
·
420 Posts
Discussion Starter #12
If the new switch doesn't fix it, I would put the old one back and try this:

Take off each front/rear light assembly off and inspect and clean any corrosion in the bulb socket and where it screws into the tub. Those light assemblies are self grounded to the tub and sometimes corrosion will cause turn signal issues.
I found a bad bulb on right taillight replaced and went to replace the fuse #27 and keeps poping as soon as I put it in. I got a short somewhere but question is where
 

·
Registered
Joined
·
420 Posts
Discussion Starter #13
Problem solved

Ok for those that don't know I drive a 2004 Wrangler SPORT.

My first problem was the following.
W/lights on I had no R Front and RR Blinker at all.
W/lights off as soon as I put that blinker on they worked but at the same time the left was also going off but dimmer.

I was told by a jeep mechanic to change the Multifunction Switch. I did that and things got worse.
I now had no blinkers, no reverse, no brakes, no hazards, at all lights on or off.

I checked the fuse box #27 and it had a blown fuse. I replaced it and immediately blew again. I am thinking I have a short somewhere in the sys. I start chasing wires and nothing. I said to my self you know what I never checked the rear bulbs and sure enough RR tail light was out. I put in a new bulb 1157 I believe and the #27 fuse was still popping. I then decided to put the old multifunction switch back on, put in a new fuse on #27 and like magic now everything works.

Here is the link on how to change your multifunction switch
multifunction turn signal switch replacement 2002 Jeep Wrangler - YouTube

Thanks to all the JEEPERS that replied to my previous post and for the advice.
 

·
Registered
Joined
·
2,972 Posts
The MFS is a finicky bastard. I've replaced mine once and out of the box it had an issue. Exchanged it for a new one and two days later I had more issues. No way I was going to pay 150$ for a dealer switch. Opened up the new one and the issue was obvious. The copper traces are way to close to each other and move around and short with each other. Opened up the original factory switch and it's the same cheap crap.

I've had my switch open 2 or 3 times to fix shorting issues. I used cut up pieces of zip ties to make shims to hold the traces away from each other.
 
1 - 16 of 16 Posts
Top