Wrangler Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 2010 wrangler unlimited spirt engine light is on. I did code check and nothing showed. Runs very rough almost like its shaking apart.
 

·
Registered
Joined
·
8,968 Posts
My 2010 wrangler unlimited spirt engine light is on. I did code check and nothing showed. Runs very rough almost like its shaking apart.
If this didn't work you'll have to take it in.

1. Insert your key into the ignition and turn it to the "ON" position but DO NOT start the engine.

2. While keeping the key pushed into the ignition cylinder, turn it to the "OFF" position and then back to the "ON" position.

3. Repeat Step 2 two more times and make sure it ends in the "ON" position.

NOTE: Make sure you are pushing it in so it doesn't catch at the other positions.

If you do it right, your dash will light up and your odometer will show all dashes. If you have any stored codes, it will cycle through them after the dashes. If you don't have any, it will show "-done-".

After that.. do a search for the codes to diagnose the issues.
 

·
Registered
Joined
·
1,279 Posts
If you have a CEL on, you have codes in the computer. Take it to Autozone or Pepboys and they'll check your codes for free.
 

·
Registered
Joined
·
8,968 Posts
I did this several times but my odometer never changed to dashes at all and no codes appeared.
I'm just throwing this out there, if you did it disregard. The first position is lock (off), the second is accessory and the third is "on". Since you're not getting any dashes did you turn the key to the "on" position, which is the third position. It almost seems like it was turned to the "Accessory" (second) position. Like I said, if you did it right disregard but some have turned it to the accessory position by mistake.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Yea I did it just like I had read but still nothing. I even had someone else try also with no luck. Just dropped off at my mechanic :( thanks for the input though!
 

·
Registered
Joined
·
93 Posts
Not sure if the JK is like this or not, but with my SRT-4 you had to do the key dance with the door shut to get it to work. Just for future reference (unless someone can shoot that down as a possibility) as you may need to check it sometime down the line.
 

·
Registered
Joined
·
605 Posts
I did this several times but my odometer never changed to dashes at all and no codes appeared.
It always works but it's tricky, you have to push the key in the whole time but make sure not to turn it far enough to where the engine turns over. The trick is to continue to push the key into the steering column during all three turns. Try it after you pick it up, I guarantee it will work.
 

·
Registered
Joined
·
28 Posts
Yea I did it just like I had read but still nothing. I even had someone else try also with no luck. Just dropped off at my mechanic :( thanks for the input though!
Yea I'm having the same problem with my 2013.
Engine light is on, not seeing 'done' or dashes/code.

Does it matter how long you have the key in the on-off positions??
To re-iterate, it goes:

On
Off-On
Off-On
Off-On

All while pushing in, correct?

Only some of the auto part stores around here do it for free and I'd really like to be able to read it myself. Don't want to get caught out on the trail and feel naked...
 

·
Registered
Joined
·
28 Posts
I re-tried today and got the dashes, then 'done'
The key dance was actually:
Off-on
Off-on
Off-on

But I'm still not convinced because the whole dash didn't light up, and no code was displayed.

After 'done', there's a chime; but upon restarting, my engine light is still on.

Am I still missing something??
 

·
Registered
Joined
·
28 Posts
Good to know. My light went off later that day and hasn't come back on.

If the system issue is legit, will the light come back on?
 
1 - 14 of 14 Posts
Top