Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently bought my second Jeep after having one for 11 years and having a great truck for a while. Had to trade it in because city life didn't agree with a Dodge Mega-cab.
Anyway got a great deal on a 2012 wrangler Sahara with the 3.6 and the 6 speed tranny and only 9,500 miles on it.I replaced the air box with a K&N air system for now, that's it.

My question/problem is this: This thing stalls out a lot with the temperamental tranny and it's not because I can't drive a stick, but the low end in this thing is so weak that I want to drive it off a cliff into the Hudson after a while. It acts NOTHING like the asx-15 5 speed in the last jeep that I had and I understand that. I was wondering if any kind of engine mods would help or should I just switch out the .321 gears in the 3rd unit for 355 or the 373 that I wish I had. I would like to keep the 321 for fuel economy, but I find that i have to wind up the engine just to be sure I don't stall and that's tough on the clutch. I get really mad sometimes and I want to fix this. Would a exhaust fix(which I will do anyway) or a Bullydog mod make this problem go away?? I would also like to put a little bigger tires on it and I know that it would make this problem a whole lot worse.
 

·
Registered
Joined
·
1 Posts
I have the same problem

Was told it was the gear ratio. BS. There has been a "sweet spot" in every stick I've driven. If I don't remember to give it gas at a stop sign or light - it stalls - a complete shutdown. PIA.
Dealer sees nothing wrong. Haven't had to rev the engine since I was 18. Now it is daily and not so much cool.
Can't find a thread about fixing this :(
 

·
Registered
Joined
·
785 Posts
Having it for long ?

When I got mine I found that it wasn't the easiest to drive, but after a while I got used to it. Mind you I have the 3.73, but I don't have to wind it, I just release slowly and as soon as I feel that it's starting to grab, I just give it some gas and let the clutch go, smooth and consistent starts.
 

·
Registered
Joined
·
280 Posts
I had a similar issue with my Impreza being that it was fully drive by wire throttle system. The system is not fluid in control from the older mechanical throttle body. For me with both my old Tacoma and my 06 LJRubi is that could get going with the rpms at or below 1000 where with my Impreza it would be between 1500-2000 most of the time. So overall its not really you its just how the system is.
 
1 - 4 of 4 Posts
Top