Jeep Wrangler Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
34 Posts
Discussion Starter #1
2016 JKUR, auto tranny..........new, weird problem. Since the weather has warmed considerably here in Reno, I 'm now getting the ESC and ABS lights coming on when, and only when, i make a full to the stop left hand turn. Doesn't do it to the right or less than to the stop turn and lights extinguish after straightening the turn after @ 10 seconds. It never did this until weather warmed up. Anyone run any into anything like this?
 

·
Registered
Joined
·
76 Posts
2016 JKUR, auto tranny..........new, weird problem. Since the weather has warmed considerably here in Reno, I 'm now getting the ESC and ABS lights coming on when, and only when, i make a full to the stop left hand turn. Doesn't do it to the right or less than to the stop turn and lights extinguish after straightening the turn after @ 10 seconds. It never did this until weather warmed up. Anyone run any into anything like this?
I would check your left wheel speed sensor to make sure it's not loose and maybe hitting something when you turn.

Sent from my SM-G965U using Tapatalk
 

·
Premium Member
Joined
·
892 Posts
Mine was when I was turning right. My right front wire was rubbing against the inside of the rim. A bit of wire clean up and electrical tape solved the problem until I can get my new wire installed. But no hurry now that the lights don't come on any more. :bop:
 

·
Registered
Joined
·
309 Posts
I've had both lights come on at startup a couple times, then they both generally go away after driving just a little bit. Any ideas on that one?
 

·
WF approved Offical Jeep Account.
Joined
·
1,466 Posts
Thanks guys............still under warranty, so will get that checked.
I've had both lights come on at startup a couple times, then they both generally go away after driving just a little bit. Any ideas on that one?
Hello renogeno and JeepJeepBeepBeep,
We are sorry to hear that you have been experiencing concerns with your vehicle. Our team recommends reaching out to your dealership to diagnose your concerns. If you would like an additional support, please send us a private message.
Jenn
Jeep Social Care Specialist
 

·
Premium Member
Joined
·
34 Posts
Discussion Starter #9
It was indeed the front wheel speed sensor, but on the right. Dealer replaced and all is good again, for now!!
 
1 - 9 of 9 Posts
Top