Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
The ESP BAS light along with the ESC Malfunction indicator lights just illuminated on my jeep. I was driving normally and have have done no hard driving ie offloading or mudding. Any ideas where to check? It's an 10 w 14 k miles so I will take it to the dealer under warranty but probably won't b able to drop it off for a week.

Thanks
 

·
Premium Member
Joined
·
12,478 Posts
Do you have a lift, or aftermarket tires?

If so, did your lift come with an adjustable trackbar? Wondering if your steering wheel is centered.

Any work done on it lately?
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #3 ·
Bone stock jeep. No aftermarket components or tires. I was just driving on a paved road with some turns and they both illuminated solidly.
 

·
I AM THERE4 I JEEP
Joined
·
12,295 Posts
In the rare change then, were you going more than 40 mph around a turn in 4th gear? I've had the same thing happen once or twice under these circumstances. Took the 2010 in for a stealership visit and no error codes were present after a computer check. Hasn't happened since but I slow down even more now. However, my rig is lifted with bigger tires so....:whistling: you need to get the sensors checked on yours.
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #5 ·
I wish that they had Haynes or Chiltons manuals available. I would like to check 2 c where the sensors are located. A standard days driving w me usually involves a couple of miles up a dusty dirt road w lots of rocks, my driveway. Maybe sensors are dirty.
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #6 ·
Alright the frigfin thing reset itself on the way home......

But still three questions

If the warning was due to a loss of traction I thought that the light would flash at you and than go out shortly afterwards.

Doesnt this year throw codes w the on off on off on? I did that and nothing.

After trying that I did the TJ way w the trip reset. That yielded weird results with the rpm pegging and cycling every 1 rpm and some other stuff on the display. What the hell was that?
 

·
Registered
Joined
·
780 Posts
Alright the frigfin thing reset itself on the way home......

But still three questions

If the warning was due to a loss of traction I thought that the light would flash at you and than go out shortly afterwards.
Correct, traction light (the squigally lines flashes during the period of loss of traction then goes out when wheel stops spinning.

Doesnt this year throw codes w the on off on off on? I did that and nothing.
I had the same error lights you did a few times over a 2 day period and I could never get any codes to show on the dash procedure, just the ----- then -done-. Took it to the Dealer and they read out an intermittant failure of the clock spring (steering wheel position sensor). Ordered and replaced under warranty. I also have a recurring MIL light at the moment, comes on every week or so for a day or so then goes off again - no codes via the dash readout.

After trying that I did the TJ way w the trip reset. That yielded weird results with the rpm pegging and cycling every 1 rpm and some other stuff on the display. What the hell was that?
Havent heard of the TJ version so have never tried it!

I am gunna grab a $15 OBD2 reader from eBay though since every MIL light or failure light I have had has never thrown a dash readable code. I currently have a recurring MIL light that the dealerships just keeps saying is fuel related, dont worry about it. Yeah right! Gotta take time off work to get to them and they tell me to not worry about it! How am I supposed to know that the next time it comes on if its the same thing or something really serious? (have had it on 5 or 6 times over the last two months now and every time they tell me its just 'fuel related, oh and you started the engine 45 times since it first came on so you were obviously not to worried about it... FFS)...
 

·
Registered
Joined
·
1 Posts
esp/bas light on

I have a 2009 lifted 4 door wrangler with third row. Lights have been on for month havent seen any difference in driving until today. Was stopping at stop sign and the slide light came on and brakes started to grab. I took off from stop sign and it would let me get over 30 mph. Any suggestions.
 

·
The Bad Guy
Joined
·
23,233 Posts
Check your alignment. Check to make sure you steering wheel is centered. Cheack all your wheel sensors.
 
1 - 9 of 9 Posts
Top