Jeep Wrangler Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
I just re surfaced my engine (2.5L) head and replaced, plugs, oil pan, all gaskets. Once I got back together everything is working and running good....Except....You know if I am posted there can't be all good.. HAHA!!! My exhaust is now so loud. I replaced the manifold gasket with new. I also disconnected the down pipe to get the oil pan out. When I took the down pipe flanged connection apart there was no gasket. One added thing is I only laid the manifold off to the side when I replaced the head. So it did not move, but I did not remove it from engine bay. THe sounds are coming from manifold area and down so it is hard to diagnose where the issue is.

I do not know what I am missing, but I am definitely missing something as it is very loud.

I hope it is something easy.

Thanks for looking as posting if you have any ideas.
 

·
Registered
Joined
·
966 Posts
Maybe you didn’t seat the manifold correctly. The six cylinder has pins to line it up on, and I’ve read on here it’s easy to miss the pins. Don’t know if the 4banger is the same way but I’ll bet it is.
 

·
Registered
Joined
·
49 Posts
The washers on the bolts between the intake and exhaust manifolds sometimes don't allow both parts to line up to the block properly leaving a gap. See if you can wiggle the exhaust manifold. Loosen the bolts, wiggle to ensure manifolds are lining up and retighten
 
1 - 3 of 3 Posts
Top