Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
383 Posts
Discussion Starter #1
Left for work this AM but my engine was acting real sluggishly, and then I noticed a flashing check engine light. Knowing this is not good, I turned around and went straight home.


Any guesses what is wrong? Also, estimates what it might cost me to repair it?



I drive a 2007 2-door JK with about 120,000 miles.
 

·
Registered
Joined
·
2,053 Posts
Possible electrical issue. Flashing engine light with a miss on my 09 with 170,000 miles. Popped a P0300 and P0301 code. Heard a clicking noise and I popped the hood and the number one and three spark plug cables were grounding to the coil mounting bolt. My shop swapped in a new coil, cables and plugs and all is well.
 

·
Registered
Joined
·
396 Posts
...Any guesses what is wrong? Also, estimates what it might cost me to repair it? ...
Turn your key off then on three times, finishing at the ON position (do not start), the dash will go all blinky, then the odometer will cycle through the diagnostic codes. (a letter followed by four numbers) Write those all down, and google them. Tell us too so we can play armchair mechanic.
 

·
Registered
Joined
·
383 Posts
Discussion Starter #4
Turn your key off then on three times, finishing at the ON position (do not start), the dash will go all blinky, then the odometer will cycle through the diagnostic codes. (a letter followed by four numbers) Write those all down, and google them. Tell us too so we can play armchair mechanic.

Amazing. Can't give you what you want.



I just tried the ON-OFF approach about 10 times and I get no codes. I tried a number of different variations. I tried the instructions on the Quadratec web page, which says turn ON, then OFF-ON three times leaving in ON, still nothing. Aaaarrrggghhh!
 
1 - 4 of 4 Posts
Top