Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter #1
I start the Jeep up this morning and noticed the rear defrost light was flashing and no heat/air would come on. Waited a few minutes and then the light stopped flashing and things worked again.

Also the seat belt light would not turn off. Eventually the chime went away, but the light still stayed on. I did remove my seat belt and re-click it, but same thing, light stays on

Anyone know what to check for? I have 43k miles so out of the bumper - to - bumper warranty.

From looking around online I see it could be the Main HVAC Controls as when the rear defrost light blinks its going through a test of some kind. I also know there is some kind of actuator under the steering wheel. Be easier to replace the Main HVAC Controls as that just pops out. However I am having a hard time finding this part online.

Anyone have any other ideas on what to check?

Ken~
 

·
Super Moderator
Joined
·
22,082 Posts
I had that issue on my 2014 and it is a HVAC module that is plug and play mine was covered under warranty. it is a small module that I believe sits somewhere behind the dash around the radio. It was a common issue at the time as module was on backorder. this was the part number at the time. 68197437ab
 

·
Registered
Joined
·
252 Posts
Discussion Starter #3
Yeah that is the part that seems to come up when googling around for this issue. The only problem is finding the part. Every place I have looked has is coming up as discontinued. I don't have auto A/C version. Just regular version but needs to have rear defrost since I have a hardtop.

Will keep looking around for the part.

Ken~
 

·
Super Moderator
Joined
·
22,082 Posts
some times they just change the last numbers so check using AC, AD etc
 

·
WF approved Offical Jeep Account.
Joined
·
1,467 Posts
I start the Jeep up this morning and noticed the rear defrost light was flashing and no heat/air would come on. Waited a few minutes and then the light stopped flashing and things worked again.

Also the seat belt light would not turn off. Eventually the chime went away, but the light still stayed on. I did remove my seat belt and re-click it, but same thing, light stays on

Anyone know what to check for? I have 43k miles so out of the bumper - to - bumper warranty.

From looking around online I see it could be the Main HVAC Controls as when the rear defrost light blinks its going through a test of some kind. I also know there is some kind of actuator under the steering wheel. Be easier to replace the Main HVAC Controls as that just pops out. However I am having a hard time finding this part online.

Anyone have any other ideas on what to check?

Ken~
Hi Ken,
I know you are looking to remedy this on your own, however, if you decide to visit your dealer, please send our team a private message and we would be happy to get you connected with a Case Specialist. Our team is available via private message!
Alex
Jeep Social Care Specialist
 
1 - 5 of 5 Posts
Top