Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
3,804 Posts
Your right side fog light is bad. If I understand you it pops a 20A fuse but not the 25A. That says it is not a direct short or the 25A would pop too. Check the wires past where you disconnected them all the way to the light for any possible damage. There could be a spot where the insulation is bad. If the wires are wrapped you will have to open it up. If the wiring is good there is an internal short in the light. I'm not familiar with the OEM fogs since I don't have them but unless you can take it apart & find why power is "leaking" to ground like a bad socket or something you need a new one. If they are sealed beam type then for sure it’s replacement time.
 

·
Registered
Joined
·
300 Posts
I agree the right light or something around it is causing the issue. The hot wire you noted is getting hot because of a current (amperage) draw that is higher than it can handle. Since it's around the right light, it adds to the probability that it is the culprit.

As Rubi 4 noted, if there was a direct short to ground, then the 25A would blow right away too. That seems to indicate that something (probably the light) is just drawing too much current.

One thing you can try to isolate the problem to the light is to disconnect it and then see if everything works ok with the 20A fuze. If it is, that doesn't absolutely mean the problem is the light, but given everything you've described, that would be a pretty good guess.
 
1 - 4 of 4 Posts
Top