Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
122 Posts
Is yours on the left Multi-Function Lever (where the headlights are)? That's where it is on my '04. I am having issues with mine too. Sometimes they work, sometimes they don't, sometimes i have to switch it on and off repeatedly to get them to work. I don't know if i'll tear into the switch and figure out the problem or just wire in a new switch somewhere else. What sucks is the previous owner just had that whole lever replaced not too long before I bought it. From what little searching I've done, they're expensive!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
yeah that's where mine is too but mine doesn't work at all I tested it to see if I was getting powerat the lights and nothing I think mines original I can't get mine to do anything yes I was thinking of putting the switch down by my rear window wiper switch I have an open bay now that it sounds like your having trouble with the same thing I think putting in a new switch would be cheaper my brother works for Dodge I'm going to call him and see if that's a repeat problem and see how much they cost to replace thanks for the info I'll keep you informed
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
O'Reilly has it for $65,99 with lifetime warranty so that ain't too bad new 1 from the dealer 160 no lifetime warranty that's what I'm going with!
 
1 - 6 of 6 Posts
Top