Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
So I am a 1 week old Jeep owner and developed a motor tick over the past few days. I found it today. Ran a compression check, all cyclinders were between 142-148psi. so I pulled the valve cover, when I got a look I saw my problem. #1 cyclinder had broken valve springs, 1st cyclinder back push rod was bent in the shape of a "V" the front push rod was M.I.A. so I pulled the head and took a look. Found the push rod in 2 halves in the lifter valley, and much to my suprise #1 lifter had popped out and was also laying in the lifter valley by cyclinder #2. Cyclinder walls were smooth as can be with absolutely no ring grooves. Pistons were very clean and nice and tight. Head goes to machine shop tomorrow to have the head resurfaced and a valve job done. order new lifters, pushrods, and a gasket set and gonna put her back together. Cam looked good, everything else looked good and rotated over smoothly.:banghead:
 

·
Registered
Joined
·
185 Posts
Now that you have a Jeep you will hear another noise. The sound of money sucking out of your pocket. Hope you get it fixed it soon. And with a little cash left to spend on it for the fun stuff
 

·
Registered
Joined
·
137 Posts
Discussion Starter #3
Im not going to be spending any cash on fun stuff for awhile. This is a straight up daily driver and thats it. If i going trail riding or mudding or anything itll be in my Bronco. I got this Jeep for the fuel economy and to get my man card back!! sold my s-10 to buy my wife a 2011 Jeep Compass. well I took her old car. 99 purple 4 dr saturn.been putting some money aside then sold that car and bought the jeep. in the 1 week I did get to drive it with the 4" lift and 33's I ran exactly 1 week on a $20 bill. I think it averaged out to about 18.4mpg
 

·
Registered
Joined
·
185 Posts
Wish I could get 18 mpg. I'm getting about 12 since I put on 33's. With the 31's I had I was getting about 17.
 
1 - 4 of 4 Posts
Top