Jeep Wrangler Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Well I just bought this 90 wrangler over the weekend and I love it! Its got the 6 cylinder and its been getting around 12 mpg since I got it which sounds low. Thats when I noticed the 4wd wouldn't work but my front drive shaft wont turn when its in 2hi. Is this the notorous vac controls screwing up? I didnt think it would have this odd combo of the shaft being locked but it not going into 4wd when put into 4wd. And does that milage sound correct if it were partly stuck in 4wd? Thanks for the help to a NEWB! :)
 

·
Premium Member
Joined
·
2,230 Posts
My 89 got about 13 mpg around town with the 4.2L and 31's when I first bought it so your not far off. Give it a tune up and it may do a little better. Your front shaft is not suppose to turn in 2hi if the axles are not locked. It should turn in 4hi. Start at the axle and trace your vacuum lines looking for leaks. If you find the axle is not locking correctly you can bypass the vacuum system and lock it manually if you want.
YJ Vacuum Bypass 4X4
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
My drive shaft coming from the transfer case is the one that wont turn freely in 2hi...... like its ingaged into 4wd. That still make sense?
 

·
Registered
Joined
·
1 Posts
scramblin'wrangler said:
My drive shaft coming from the transfer case is the one that wont turn freely in 2hi...... like its ingaged into 4wd. That still make sense?
If your drive shaft won't spin freely in 2hi then it's the actuator on the front axle, it's by the passenger side tire and it's round. Mine failed and I changed it and it took care of the problem. If it's not going into 4wd then it's the vacuum switch on top of the t-case. It's round and about 3 inches long with 4 different vacuum lines coming out of that. If you change both things and you still have problems let me know, there isn't a lot I haven't done on my jeep.
87 jeep yj 4.2 inline 6
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
K well I replaced the vac lock actuator with a posi-lok manual cable and it goes in and out perfect....... but it still wont drive the front wheels at all!
 

·
Registered
Joined
·
11 Posts
scramblin'wrangler said:
K well I replaced the vac lock actuator with a posi-lok manual cable and it goes in and out perfect....... but it still wont drive the front wheels at all!
Bad transfer case or shift linkage not adjusted properly.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #7
haha, i got it now..... yesterday I went back out and messed with it. I wasn't sure how far out the posilok cable had to come out to engage.The 4wd light came on but it wasnt in all the way. Shes working real good now. :)
 

·
Registered
Joined
·
6 Posts
Similar issues.

Hey all, I recently bought a 92 wrangler and after the first day i got it stuck. I shifted into 4 wheel low to try to get out, and it shifted very hard. After I got unstuck I tried to shift back into 2wd, and it wouldn't shift. I can shift from 4hi to Neutral to 4lo, but not into 2wd. Any ideas? :(
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
Did you turn the engine off before going into 4lo? Cause I'm thinking you have to shut her down then put it in and start back up.
 

·
Registered
Joined
·
6 Posts
Did you turn the engine off before going into 4lo? Cause I'm thinking you have to shut her down then put it in and start back up.
No I did not actually. (probably what caused the issue) And I was surprised when it engaged when i pulled the lever straight back rather than having to move it to the right. I have tried putting it into 2hi when it was off, but the lever wont budge past 4hi.
 

·
Registered
Joined
·
421 Posts
Snow, I thought I had the same problem...then I realized that I had to force the 4wd shifter to the left to get it into 2hi :banghead: It was a bit stiff, so I sprayed it with some lube and she works real good now. :doh:
 

·
Registered
Joined
·
6 Posts
Snow, I thought I had the same problem...then I realized that I had to force the 4wd shifter to the left to get it into 2hi :banghead: It was a bit stiff, so I sprayed it with some lube and she works real good now. :doh:
Well the odd thing is my shifter technically should have to go left to go from 4 hi to 4lo, but it doesnt. and it probably doesnt help that today my skid plate that houses the tcase and tranny dropped out on one side because of rust.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #14
Haha! Thanks man. ;)
Speaking of questions about posi-loks... when you pull out on the button/lever do you have to drive it a few feet then pull it a bit more to engage it like it needs to line up the splines a bit before snycing?
 

·
Registered
Joined
·
7 Posts
I have a 90 YJ with a 2.5, 4 cy, 4wd is not working. Transfer case shifter is workin properly. U can tell it is low range but front wheels r not pulling. Where do i need to start checking first? Raised front end off ground, transfer case in 2 hi, turned front drivers side wheel bh hand and front driveshaft turned? Dont think its supposed to do that? Help please !
 

·
Registered
Joined
·
29 Posts
Discussion Starter #16
Your vacume lock system is locking the front axle in and not letting it out like mine was. seriously the easiest way but not cheapest way is to get a posi-lock system for it. But that sounds like thats what your problem is...... dont worry..... fairly simple fix. ;)
 
1 - 16 of 16 Posts
Top