Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
So I have this rattling sound from the front of the Jeep when I'm driving. It only happens when I'm moving. Also when I'm in 4wd I have squeaking from what sounds like the front drive shaft area. Wondering if anyone knows what it could be? Thanks in advance
 

·
Registered
Joined
·
8,397 Posts
Tough to diagnose without hearing it, but broken or loose swaybar links can rattle.

On your 4wd squeak, it is most likely a front u-joint going out.
 

·
Registered
Joined
·
5 Posts
Test

Lift the front wheels off the ground, now grab the top and bottom of the tire and try to move it back and forth... Observe your spindle on the other side. Focus on the upper ball joint. If the spindle is moving at the ball joint? you need ball joints (just did mine last weekend...what a difference)... If you feel a movement "clicking" and the spindle is stable? investigate your wheel bearings.... Now with the passenger tire on the ground and the drivers side in air... grab the tire horizontal (front and back) If there is a clicking observe your tie rods joints and every thing up to the pitman arm...Now put it in 4wd and accelerate /decelerate rapidly... if the noise is predominate then it is your arm bushing or if you have "long arms it's your "Johnny joints (adjustable by the way).... Definitely check stabilizer bar... some installer of after market don't use shims/washers and bottom the threads on the bolts without actually tightening the bolt.... if that doesn't work? then grad a six pack.. drink it and live with it til it breaks... hope this helps...just did it
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
Thanks for all the advice guys. And sorry it took so long to respond computer has been down and I just got data on my phone to use the app. That being using advicr and tips that everyone here have me I finally tracked down what I hope is and will fix my problem. turns out that my front drive shaft is the problem so I will be replacing that asap.
 

·
Registered
Joined
·
8,397 Posts
Thanks for all the advice guys. And sorry it took so long to respond computer has been down and I just got data on my phone to use the app. That being using advicr and tips that everyone here have me I finally tracked down what I hope is and will fix my problem. turns out that my front drive shaft is the problem so I will be replacing that asap.
Yeah, likely our driveline is fine, but your driveline u-joints are shot.
 
1 - 7 of 7 Posts
Top