Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter · #1 ·
It just rained a lot here so half the roads are flooded, so i had to take a highway to get to weights this morning. When i was coming home i was going about 71mph and i would hear this low-pitched growl. I do have a k&n cai, would that be the noise i was hearing? I was in 4th gear in my auto 11 rubicon.
 

·
i'm back
Joined
·
13,706 Posts
like a mud tire on pavement growl? :confused: or some mechanical noise? more information please...
 

·
Registered
Joined
·
449 Posts
Discussion Starter · #3 ·
like a mud tire on pavement growl? :confused: or some mechanical noise? more information please...
To be honest - i dont know. It seemed to happen more around turns and whenever the wind picked up. Then when i was gassing up the steering felt kinda funny when i left.
 

·
i'm back
Joined
·
13,706 Posts
i wonder if your locker engaged or something... how's that working? got some dirt close that you can check? :whistling:
 

·
i'm back
Joined
·
13,706 Posts
i'm wondering... could be your locker malfunctioned or maybe your ring and pinion? idk.. weird if it was only at a certain speed... for a minute i thought driveshaft.

might want to bring it to a dealership if you have warranty left... before it turns into something bad. otherwise, it might not be a bad idea to open the front differential up... see how things are looking in there.. :thumb:
 

·
Registered
Joined
·
666 Posts
To be honest - i dont know. It seemed to happen more around turns and whenever the wind picked up. Then when i was gassing up the steering felt kinda funny when i left.
Check tire pressure. Easy and important.

If soft top, check zippers and seams. An opening can make a strange world of noises.
 

·
Registered
Joined
·
449 Posts
Discussion Starter · #9 ·
Just went driving around. And now whenever i press the brake the front end dives down so much farther than it ever has before, plus it seems to sag towards the passenger side.

Will check pressure now even though i checked it 3 days ago.

Problems did start today though.
 

·
i'm back
Joined
·
13,706 Posts
sway bar rubbing somewhere? or sway bar link disconnected?
 

·
Registered
Joined
·
449 Posts
Discussion Starter · #11 ·
sway bar rubbing somewhere? or sway bar link disconnected?
Swaybars are fine. But i think i found the problem! It doesnt have a lift on it!!! :D kidding. Its always had that problem :)
 
1 - 11 of 11 Posts
Top