Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Premium Member
Joined
·
2,939 Posts
Discussion Starter · #1 ·
Is it just me who's experiencing this? I have a 2007 and I'll be going on my 3rd gas cap due to the 0455 error code and engine light. Any tips or tricks to extend the life or avoid the dreaded code?
 

·
Registered
Joined
·
4,768 Posts
When I had that error, It actually wasn't the gas cap. While off roading I had something contact the Evap canister and pull the plug loss. The code can come up for any leak in the fill tube or any Evap Canister problems, Not just a Gas cap problem. Just a thought.
 

·
Premium Member
Joined
·
2,939 Posts
Discussion Starter · #3 ·
When I replace the cap the light always goes out so I suspect that's the main issue but I was unaware of the filler tube being a possible source
 

·
Registered
Joined
·
33 Posts
The computer can't always distinguish between a loose/missing gas cap and a leak in the evap line somewhere, so it can throw that code erroneously sometimes. You said replacing the cap always makes it go away, but it seems weird that you would get 3 bad caps...sounds like something isn't sealing up right, and maybe just the act of removing and replacing the cap fixes it. Check for debris around the seal on the filler tube, maybe? :confused:
 

·
Registered
Joined
·
47 Posts
07 here too. Threw that code with CEL two weeks ago for the first time. Had it read and reset. Then a few days ago I get "GASCAP" on my digital readout when I start the beast, no CEL. Turn engine off, remove cap, reinstall cap, problem gone (for now.) Will watch this thread and follow up if I have any new details. I have a feeling the o-ring on the cap isn't sitting right; either it or the contact with the fill tube is dirty.
 
1 - 6 of 6 Posts
Top