Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
453 Posts
Discussion Starter · #1 ·
Yesterday i took off my intake and cleaned my engine good with degreaser for engines. Now the jeep doesnt start as powerfully as it did before and it has a gasoline smell to it. What could this be?
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #3 ·
i used tough stuff, from autozone, ive sprayed it all over, ive even cleaned out my throttle body with it too by removing it but i made sure it was dry before i put it back on
 

·
Registered
Joined
·
8,402 Posts
Well, I think the first thing I would do is buy a can of "Throttle Body Cleaner" and pull the throttle body back off and reclean it. Douche out all the holes and clean the attached sensors. (Just don't pull it off and and use Engine Degreaser on it again simply because you have it....get the right product for the application.)
 

·
Registered
Joined
·
199 Posts
Yeah you probably just didn't get all the degreaser out of the throttle body, clean it with throttle body cleaner and let it soak instead of using degreaser.
 

·
Registered
Joined
·
199 Posts
bmbillups said:
Even if there is a little degreaser in it why would that make it smell like gasoline?
It might be clogging up some of those little fuel ports, cause a gas smell to back up into the engine bay. What year model jeep and motor do you have?
 
1 - 8 of 8 Posts
Top