Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
594 Posts
Discussion Starter · #1 ·
Looking for a FSM for a 1990 wrangler gage cluster( have a pink wire to clock no power also left dash blinker quit replaced bulbs in all six spots now none of them work (left and right blinker,high low beam,emergency brake)ect ect
 

·
Premium Member
Joined
·
3,236 Posts


For the center warning panel, did you try cleaning and re attaching the two connectors at the bottom of the "boomerang"?



 

·
Registered
Joined
·
594 Posts
Discussion Starter · #3 ·
DREDnot thank you so much I think this will help a lot
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #4 ·
Need some more help DREDnot cleaned all connections now left turn and high beam burn together and flash together also looking for the ground that is hooked on the emergency brake assy
Thanks for the help
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #5 ·
Bump
 

·
Registered
Joined
·
263 Posts
possibly backfiring power through the ground? Just a guess worth investigating. Ground receiving power kept my jeep from starting for a months till I found it.
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #7 ·
That's what I think is happening is some feedback due to a bad ground
Do I have to pull emergency brake assy to access ground wire also are there any others
Under dash that I need to find
 

·
Premium Member
Joined
·
3,236 Posts
Mine has a lot of crazy stuff from the PO's immobilizer chip, but you can see the ground ring terminal at the brake assy mount's screw. The maroon one is for all the dash stuff, and the blue one is a hard wired ground to rear of the tub. the





Also make sure these on either side of the headlights are good and clean.

 
1 - 8 of 8 Posts
Top