Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have searched the threads for a solution, but cannot seem to find what I need. I have wired a pre-2002 hardtop to my 2003 TJ (I have purchased the pigtail adapter for the rear connection), and when I reconnected the battery, the defroster light was on and remained on. I have been chasing wires and everything looks sound, if you have any idea what is going on here, I'd love to know...
 

·
Registered
Joined
·
951 Posts
Did u go back through all your wiring thoroughly and make sure you didnt wire something incorrectly? Could be bad defroster switch if everything else works
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Going through them all again, but it's only a few wires, it doesn't make any sense why the relay is not getting pulled in.
 

·
Registered
Joined
·
6,886 Posts
Go to jeepforum.com and search. There have been a number of threads related to defroster light issues.
 

·
"Seamed Like a Good Idea
Joined
·
1,200 Posts
I would check the Jeep side of the pigtail and determine if the power is truly coming from the defroster wire or if it perhaps is coming from another wire that got crossed up.
 

·
Registered
Joined
·
799 Posts
It is probably mis wired. Check the connector that the defroster power from your harness ties into. You probably have the wrong pins. At least that is what I did and my indicator was on all the time.The white and black connector behind the left dash speaker.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Had the power wire crossed up. Hate those 100 point connectors. Think I need a Back-eotomy from being under there so long. Thanks for the help guys
 

·
Registered
Joined
·
31 Posts
OK
Now i am confused
I have a 2006 Jeep and bought the Hardtop wiring kit for it (03-06)
The Hardtop is a 2002. The Pigtail from the harness is square and the Hardtop Pigtail is a rectangle. I need an adapter between the 2 and Quadratec does not have it. Help? How did you adapt yours?
 

·
Registered
Joined
·
6,886 Posts
OK
Now i am confused
I have a 2006 Jeep and bought the Hardtop wiring kit for it (03-06)
The Hardtop is a 2002. The Pigtail from the harness is square and the Hardtop Pigtail is a rectangle. I need an adapter between the 2 and Quadratec does not have it. Help? How did you adapt yours?
And I am confused, here you say you have a 02 top and this thread says 03 (typo?) http://www.wranglerforum.com/f5/hooking-up-hard-top-141750.html


No offence, when you spread the same question across several threads, it's hard to get you the answer. The answer to this is in this thread right above your question. http://www.wranglerforum.com/f5/tj-hardtop-wiring-128802.html You can modify for free or you can buy here Hard top wiring pigtail or plug FIT ANY YEAR TOP TO YOUR JEEP WITH plug
 

·
Registered
Joined
·
951 Posts
I have one of the adapters for, jeepsareus and dont need it, il take 30$ shipped for it, otherwise they charge about 70$ shipped
 
1 - 14 of 14 Posts
Top