Jeep Wrangler Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
Noticed my head and taillights won't come on last night got home from work and my battery was dead, jumped it and now my wipers nor lights work any suggestions?
 

·
Registered
Joined
·
755 Posts
If you fill out your profile that might help. My head light switch is on the dash on my 00, on my 04 it is on the stalk/multi switch. Which do you have?
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
I checked a few but the description isn't great on the fuse box. Would a fuse cause wipers and head/tail lights not to work?
 

·
Premium Member
Joined
·
4,934 Posts
Just get an ohm meter or continuity tester out and check all the fuses. If it is a fuse, you'll find it.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #7
Failed to mention that my clock spring has been bad for awhile so I'm going to start by replacing it
 

·
Registered
Joined
·
566 Posts

·
Premium Member
Joined
·
4,934 Posts
He only has 29 posts. Maybe this was a hit and run! :p
 

·
Registered
Joined
·
69 Posts
Discussion Starter #13
Easy fellas. Sorry but the solved post was for the dead battery. As for the issue I'm having I have a clock spring problem my airbag light has been blinking for a month or so plus my horn hasn't worked in awhile. If you look at a print it all ties in together and I'm hoping the multi switch gets its feed from the clock spring so I bought it yesterday going to install Saturday. Fwi I paid 250 at dealership (yea I know I could have got it cheaper online) but I heard mopar beefed up the spring so I guess time will tell. If not I guess I'll buy a new multi switch.
 

·
Premium Member
Joined
·
4,934 Posts
That is awesome! I just had my dashboard out a little over a month ago so I got to see the inner workings of the clockspring. Glad to hear that all is working now.
 
1 - 15 of 15 Posts
Top