Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of Aug's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
688 Posts
Discussion Starter · #1 ·
So about a year ago, my 1st speed of the 4 speed switch for my ac/heat decided to stop working. 6 months later, my 2nd speed decided to stop working. The 3rd and 4th speed are at the same pressure as normal, and haven't lost any oomph. Yesterday the directional switch decided to go out on me. Luckily it is stuck in the defrost position, so I can defrost my windows in the morning. The ac/heat switch is working just fine. Any suggestions?
 

·
Registered
Joined
·
1,098 Posts
Loosing speeds on the fan switch sounds like a blower resistor is bad (could also be the fan speed switch), the directional problem sounds like a vacuum line may have come loose.

You don't have to buy the whole panel, the fan switch is about $25 at the dealer.

Start by looking at the back of the panel (pictured above). Sometimes the connectors attached to the fan switch and/or the climate mode switch are melted. It isn't too hard to access that panel.
 

·
Premium Member
Joined
·
206 Posts

·
Registered
Joined
·
688 Posts
Discussion Starter · #7 ·
It's been awhile since I posted here, but I had 2 problems. The first was a loose hose going into the manifold. That fixed my directional issues. The second was a bad Heater Resistor. This was a fairly easy swap.

Problem 1: 2 cents for a zip tie.
Problem 2: 18 bucks for the part.

I now have all speeds and directions again. My contacts thank me the most.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top