Jeep Wrangler Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
719 Posts
Discussion Starter #1
So a light goes red i push on the brakes only to change lanes and pucker. I would have hit someone if they would have been next to me. The jeep pulls hard to the left when hitting the brakes only. It does not pull when going backwards and hitting the brakes. The e-brake does not make it pull either. It was fine five minutes before this.


I am not leaking any fluids. Nothing seems to be broken. Tires seems great. They loog almost new. Has plenty of brake fluid.



Please any ideas at all. I was going to do a full tune up this week to get it ready for a smokey mountain trip next weekend. So this issue needs to be fixed ASAP.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #2
http://www.youtube.com/watch?v=iRusuKjxwTU

This is a video of it in action. the last time i hit the brakes i let the wheel go to show you how extreme it is.


PLEASE dont say how i should not try to record while driving. Yes i know its wrong. I was the only one on the road and i could see for a very long way. So please either help with the issue or be kind and keep the comments to yourself.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #4
gonna go jack it up and see if one of the brakes are not letting go or not grabbing at all.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #5
Any idea on how to fix it?
 

·
Registered
Joined
·
19 Posts
I would check your rear drum brakes if the front ones don't show any problems. E-brake is tied in but some of the mechanics of the brake is circumvented. don't take them apart unless you need to though. reassembly requires some special tools.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #9
with the front axle in the air the front right rim has play up and down. It is tight left to right.

By play i mean its enough to feel it with ease and way more then the left. left side felt like no play at all. right side has play.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #10
both rims spin with the same amount of force. Both rims brake as well. I am thinking its not enev a brake problem.

Any more ideas now?
 

·
Registered
Joined
·
1,150 Posts
It's the caliper. It will not do it when it's cooled off. Take it for a ride heat it up. Then it will start again. Then check it.
 

·
Premium Member
Joined
·
2,866 Posts
with the front axle in the air the front right rim has play up and down. It is tight left to right.

By play i mean its enough to feel it with ease and way more then the left. left side felt like no play at all. right side has play.
If you can rock the tire back and forth with your hands at the 12 and 6 positions with the tire in the air, you probably have a shot unitbearing.

There should be zero play.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #13
Yes i would say 100% the unitbearing is bad. It has been squeaking at speeds since my last off road trip.

I will put my tire back on and head to the auto store. wish me luck guys. Ill be back on in an hour 1/2 so please if you come up with anything else let me know.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #14
I just put a new front left caliper on the jeep and made sure to get all the air out of the lines. Still the jeep pulls hard to the left when stopping.
 

·
Registered
Joined
·
1,315 Posts
I had my caliper seize on the drivers side but it was do bad it would smoke. It cools and then releases but as do as it heats up its stuck again.
 

·
Registered
Joined
·
1,315 Posts
The other side should not be working and therefore it pulls opposite.
You are correct. The OP says it pulled left and he changed the drivers side which was the wrong one to change. He should have changed the passenger. All he has to do is just keep driving when it does it and smoke will show him the correct side, no question!
 
1 - 20 of 21 Posts
Top