Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Thanks for letting me join your forum! I'm new here but not new to jeeps. Background: I have a 2006 tj with a 4.0 that has 50,000 miles. I parked it about a year ago and it hasn't been started. I went to start it today and with a new battery it turns over but won't start. I put in new gas. When I spray starting fluid into the throttle body it fires. I checked the relays. I checked the fitting at the fuel rail and its getting fuel there. I replaced the throttle position sensor. I pulled and cleaned both the cam sensor and crank sensor. Should I replace them both or where should I go from here? Thanks in advance. Also I'm a paralyzed veteran so I'm having to have people help me with those things.
 

·
Premium Member
Joined
·
656 Posts
Did you check fuel pressure? Don’t assume that cause fuel squirts out of the test port that is the same as checking fuel pressure with a gauge.

Also so you have spark?
 

·
Premium Member
Joined
·
767 Posts
Thank you very much for your service and sacrifice, and welcome to this forum.

Is the Check Engine Light on? If so, check the codes using the on/off trick. If the CEL is not on... plug in an OBD II scan tool and see if there are any codes or pending codes. If you don't own an OBD II scan tool they are free to use at most part stores or can be purchased online through Amazon for under $50. If you're throwing a code or two, that would be a good place to start diagnosing.
 

·
Registered
Joined
·
5,007 Posts
If it starts with starting fluid you've pretty much nailed it down to a fuel issue. I suspect your fuel pump is not putting out enough pressure.
 

·
Registered
Joined
·
3,858 Posts
^x2^ agree

And it pretty much eliminates it being the cam or crank sensors. You might try seeing if it will start if you give it some gas (pedal) as it cranks to see if it will start. If so the IAC may be stuck (closed). Otherwise pull an injector to see if you are getting any output.
 

·
Registered
Joined
·
15,677 Posts
Low rail pressure until proven otherwise

No parts darts just check rail pressure

The of rail pressure 49 psi progress to noid light


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #8 ·
Thanks everyone for the responses. Its and automatic and I have not checked the neutral safety switch. I probably should have started with that. I won't get a chance to work on it until later this week but when I do ill report back! Thanks again!
 

·
Registered
Joined
·
15,677 Posts
If it cranks-turns over it is NOT the neutral safety switch

The starter will not run at all with a neutral safety switch issue


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,898 Posts
Check the fuse behind the glove box to see if it is blown. This is a fuse in the "Run" circuit and your Jeep will not run if it is bad.
 
1 - 10 of 10 Posts
Top