Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hey everyone I guess you could say Im new here. Iv been a member since back in 2010 but had my jeep stock and never came on here much. I just tried to log on and couldnt remember my user name etc so here I am haha.

Anyways, my Wrangler Sport was bone stock and I just recently added the mods in my sig below. I love everything except the exhaust. I shouldve known better than to mess with the stock cats on an underpowered stock motor but I changed them out with SLP high flow cats and installed the MBRP stainless off road exhaust which relocated the muffler and is straight thru.

Since the exhaust change Im getting an engine code, dropped from 18mpg average to 16mpg, and low end power under 3k rpm feels mushy compared to before. High rpm is def better as expected.

Question is...should I swap the straight thru mbrp muffler for a chambered type exhaust to get some more back pressure??? Or did I go wrong with the high flow cats?

Also, does the engine check light pull any timing back or mess with fuel curves etc? Thanks for any and all info!
 

·
Registered
Joined
·
135 Posts
Sounds like you may need some back pressure to bring back low end torque. Get some at a local auto parts store to read ur codes so you can narrow it down. My guess it ur code will point to ur O2 sensory after cat. I'd be surprised if there isn't a flash out there to help or a spacer for your O2 sensor to fix the codes...

Good luck & let us know what you end up doing.

PS, you could always bolt on a supercharger:)
 

·
Registered
Joined
·
5,616 Posts
You can read the coad yourself . Just turn the key on then turn it off and on three times without starting the jeep. The cold will flash on the dash. I have more of or less the same setup and mine keeps giving me the cold for a delay on the O2's. Don't remember what the code # is.
 

·
Registered
Joined
·
619 Posts
Running 4.88s with 33s I guess you should be happy to have good top end performance right?

Did your mpgs drop after all of the mods, or just after the exhaust work?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Il def pull the code up in the morn and see what its saying...Iv never thrown a code til the exhaust and from what Iv done its def gotta be the cats/o2 sensors not liking the setup. I can live with the code for now as long as the computer doesnt go in to a safety type mode and pull fuel and timing back etc?? Anyone know if this is true?

I actually dont have the 4.88's on yet Im getting them done on the 5th...so my plan was to open the exhaust a bit since low end shouldnt be a problem with the gears. But the drop in gas milage etc leads me to think im prob losing hp too. Id assume a good exhaus setup would increase mpg a bit??

Thanks for the replies very much!! And dont tempt me on the s/c idea haha
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Also, I did disconnect the battery and did the computer reset...also installed an AirRaid Cai. Gas milage and engine light started right after the exhaust tho
 
1 - 7 of 7 Posts
Top