Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
So the last couple days every time i use my turn signal the "high beams" come on when I have the lights on.

When the turn signal shuts off The high beams stay on...but if I wiggle the stalk a bit I can get the lows to come back...but not always.

Seems to be a lot more clicking from the fuse area as well....it could just be that I am freaked about it now so I am noticing it more. I can't find any fuses that are bad....and I replaced the turn signal stalk a couple years ago.

Anyone have any ideas???
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
Thanks Jerry....I thought that would probably be it...but I just couldn't believe after only two years I would have to replace it again!!! What these things only last a couple years out at a time!!!
 

·
Knows a couple things...
Joined
·
49,618 Posts
Stock 55w headlight power? Was your first replacement headlight switch OE or aftermarket from a chain auo parts store like Autozone?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
Jerry Bransford said:
Stock 55w headlight power? Was your first replacement headlight switch OE or aftermarket from a chain auo parts store like Autozone?
I either bought it from the dealership or from napa. Honestly I don't remember which. I just bought another one from napa and it has a three year warranty. The dealership only had a one year guarantee on another new one at twice the price. I would think the napa part is OME isn't it Jerry? Should I take it back and get the dealership one?
 

·
Knows a couple things...
Joined
·
49,618 Posts
Few parts sold by auto parts stores are OEM. When they can even get OEM, which isn't often, they normally have to order them. I gave up on all of them for OEM parts, even NAPA, they just aren't interested in carrying OE parts since there is less margin on them.
 
1 - 6 of 6 Posts
Top